Is this a bug in Xcode 4.3?

Discussion in 'iOS Programming' started by mikezang, Mar 25, 2012.

  1. mikezang macrumors 6502a

    Joined:
    May 22, 2010
    Location:
    Tokyo, Japan
    #1
    I use storyboard to build a new project, when I change "iOS deployment target" to 3.2, I got message "Storyboards are unavailable on iOS 4.3 and prior.", then I changed it back to 5.1, but the error is still here, even if I clean and rebuilt!

    Is this a bug?
     

    Attached Files:

  2. jnoxx macrumors 65816

    jnoxx

    Joined:
    Dec 29, 2010
    Location:
    Aartselaar // Antwerp // Belgium
    #2
    There is somewhere another "build option", with min base SDK. You are building for NOW iOS 5.1, but not the min option ;) so you need to go to Build settings, and find where it still says below 4.3 :)
     
  3. mikezang thread starter macrumors 6502a

    Joined:
    May 22, 2010
    Location:
    Tokyo, Japan
    #3
    I found all settings but no 4.3, what can I do next?
     
  4. waterskier2007 macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    White Lake, MI
    #4
    Did you look at the settings for your target? You are looking at the settings for your project in the image you put up but not the target app
     
  5. mikezang thread starter macrumors 6502a

    Joined:
    May 22, 2010
    Location:
    Tokyo, Japan
    #5
    There is no any 4.3 even in Target settings, but I fixed the bug.

    I closed Xcode and reopen my project, then do clean and rebuild, so anything is ok! It is very simple!

    I still think this is a bug of Xcode, hope Apple will fixed next release.
     
  6. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #6
    Be sure to report bugs to Apple, so they are aware of them.
     

Share This Page