Is this a Handbrake issue, or an iTunes issue?

Discussion in 'Apple TV and Home Theater' started by kavika411, Jul 5, 2011.

  1. kavika411 macrumors 6502a

    kavika411

    Joined:
    Jan 8, 2006
    Location:
    Alabama
    #1
    Thanks for reading. I've looked but can't find anything on this particular topic. I appreciate anyone's thoughts.

    I have lots of music DVDs. I've been ripping them on Handbrake. Unlike the DVD movies I rip via Handbrake, the music video DVDs I rip are - for lack of a better word - smaller. In other words, when I watch a Handbrake-ripped movie DVD, it fills the screen. When I watch a Handbrake-ripped music video DVD, it has a large black box around it, making it much smaller.

    Is there a setting I'm missing on Handbrake? Is there a setting I'm missing on iTunes?

    I appreciate anyone's thoughts.
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    Many music videos are "letterboxed" on DVD. Handbrake should have a setting to crop (remove) letterboxing.
     
  3. kavika411 thread starter macrumors 6502a

    kavika411

    Joined:
    Jan 8, 2006
    Location:
    Alabama
    #3
    Thank you for your response. I'm not quite sure what letterbox is, but I think I may not have said the issue correctly. The black box is all around the music videos (ripped from DVD). It is not just a black bar at the top and the bottom to make it wide screen; the whole image has a large black box around it so that the viewable area is much, much smaller than the screen. To say it another way, this "boxing" only occurs with music video DVDs, and not with movie DVDs.

    Hope that makes sense. Thanks again for your response. Appreciate any more insight.
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    Hmm, if cropping the video didn't help then I'd better wait and see whether anyone has any better ideas.
     
  5. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #5
    it probably is letter boxing.
    chances are your music dvd have a wide screen image, but are recorded on the disc in 4:3 (the older square-ish television standard), so the top and bottom black bars are hard coded into the image.

    when you play them back, it sees 4:3 image, so whatever you're playing them back on adds the black bars on the sides to make it wide screen.

    in handbrake you'll want to get the disc loaded, open the picture settings and also the preview window.
    you will probably see a 4:3 image with top/bottom black bars, you'll need to set cropping to custom, then in the 4 boxes, adjust the top and bottom numbers higher until the black bars in the preview image go away.

    ------
    with your current videos, you should also be able to set the aspect ratio on your TV, to zoom the image to make it fit.

    what you are seeing is quite common, several stations (NBC for one i think) will air their shows in letter box on their standard def channels, so if you're watching it on a 16:9 TV, it will appear as a small image surrounded by black bars. (or if you're set up incorrectly, the image will be distorted, and only have black bars at the top and bottom, but will be stretched out left and right making everyone look short and fat.)
     
  6. MBSL600 macrumors newbie

    Joined:
    Jun 24, 2011
    #6
    Another Idea:
    I used to have the same problem (I am Big on 16:9 and 5.1 sound)...in HandBrake, you will need to change your display size(picture tab) to a 16:9 setting (992x480 / 568x320 / 480x270) using custom and cropping set to all 0s. It works well for me and my music DVDs. The settings above are just examples of the (H x 1.78-1 = 16:9) which work across my platform of 3xAppleTV JB / iPad-1 JB / iPhone 3G JB / AppleTV2...
     
  7. kavika411 thread starter macrumors 6502a

    kavika411

    Joined:
    Jan 8, 2006
    Location:
    Alabama
    #7
    Wow. Thanks for the great input. I tried the Picture Setting/Preview Window mentioned two posts above, and that helped immensely. I am also about to try the trick mentioned immediately above.

    I have one - and only one, I promise - more question regarding ripping music DVDs. Like the letterboxing, this next issue seems to be unique to ripping music DVDs - whether it be concert DVDs or music video collections. I don't know how to describe this well, but I'll try, and I'll also try to add a picture.

    On the music DVDs I have ripped, there is so often a "blurring" (for lack of a better word) of lines, so that lines are re-composed (again, for lack of a better word) with tons of tiny horizontal lines. It only occurs when there is movement. I will try to show an image below.

    [​IMG]

    Does anyone know what causes that strange blurring in music DVD ripping, and whether there is a Handbrake has a setting to fix it? Again, it seems to only be in music DVDs, and it is only when there is fast motion.

    Thanks.
     
  8. kavika411 thread starter macrumors 6502a

    kavika411

    Joined:
    Jan 8, 2006
    Location:
    Alabama
    #8
    Alright. I gave it a shot, but I'm not the savviest at the Handbrake nomenclature.

    After I went to Picture Settings, I changed the "Cropping" to "Custom" and then the four cropping numbers to zero; so, I think I got that part. I can't follow the other stuff, though. Am I simply changing "Width" and "Height" in "Picture Settings" to one of those 16:9 ratios? Do I need to checkmark "Keep Aspect Ratio"? Does "Anamorphic" remain at "strict" or do I put it at "custom"? And finally, do I change the "Modulus" to something other than "16"?

    Thanks so much for your time.
     
  9. AdrianK macrumors 68020

    Joined:
    Feb 19, 2011
    #9
    Your video is interlaced, google it if you want an explanation. In handbrake, go to 'Picture Settings' (or the video tab if you're on windows) and enable Deinterlacing. If you can, go with slowest (gives best results).
     
  10. MBSL600 macrumors newbie

    Joined:
    Jun 24, 2011
    #10
    Size
    1. Uncheck "Keep Aspect Ratio"
    2. Change "height" to one of the 16:9 ratios (480)
    3. Go to area below and change Anamorphic to "Custom"
    4. Modulus: 8 (this works well for me)
    5. Display Width: 992
    6. PAR Width: 992
    7. PAR Height: (will populate to be your source height)
    8. Display Size: 992x480 (should be showing the 16:9 setting you were trying to achieve)

    Cropping
    Custom: 0,0,0,0

    Good Luck...
     
  11. kavika411 thread starter macrumors 6502a

    kavika411

    Joined:
    Jan 8, 2006
    Location:
    Alabama
    #11
    Thank you both for taking the time to respond. Such a great forum.
     
  12. slothrob macrumors 6502

    Joined:
    Jun 12, 2007
    #12
    I believe that's a classic example of Telecined material. The double image is the result of inserting a meld between 2 frames to fill in a gap between 24 fps film and 25 or 30 fps TV. The lines, or combing, are the result of combining two interlaced images, I believe.

    My understanding is that this isn't precisely the result of interlacing, though it does reflect artifacts from being interlaced. So, the common recommendation seems to be to turn on Decomb and Detelecine, not Deinterlace. I don't know if Deinterlacing will hurt anything, but the other two usually solve any problems I have with this.
     
  13. AdrianK macrumors 68020

    Joined:
    Feb 19, 2011
    #13
    Never considered that.

    kavika411, could you drag one of your source VOBs from a music video with the combing issue in to media and paste the output in your post?
     
  14. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #14
    Use Decomb as mentioned above.

    Fwiw I use Decomb by default on all of my own presets. It works quite well and is faster as Deinterlace will deinterlace *every* frame whether it needs it or not. Decomb will selectively apply either Deinterlacing or a Blending on only the frames that need it.

    https://trac.handbrake.fr/wiki/Decomb
     

Share This Page