Is this a hardware flaw? (WD MyBook External drive)

Discussion in 'Mac Accessories' started by style, Jan 8, 2008.

  1. style macrumors member

    style

    Joined:
    Sep 27, 2005
    #1
    Hi,

    I noticed problem with my external drive lately that sometimes it can't read files that I copyed to it. When this happen, finder will froze and after maybe 2-3mins, it shows a error message.

    Therefore I was testing the drive by copying some files to it and copying it back. When it was copying the files (2GB of photos) from internal to external drive, it didn't give any error message and just seems like its working fine. When its done, I tried to copy those files back to the internal drive but it won't copy back and will give a error message at some point: progress bar stops, 2-3mins later show up error message of not able to read / write. I tried this with FW800 and USB both have same problem so I'd say its not the interface's problem.

    This didn't happen until recently.. seems strange to me but I feel that its a hardware problem as when it stops copying at some point, the drive gives out some sound (tick..tick.........tick..tick........) which to me its "trying to read data". I think the reading/writing head is flawed. I will probably try to backup my files on it as much as I can then ask for a replacement, just that I want to know if anyone else is experiencing the same problem as me. Thanks

    What do you think?

    Setup
    WD MyBook Studio Edition 500GB (bought in Nov 2007)
    OS X Leopard 10.5.1
    HFS+ Journaled formatted
    Using it with MacBook Pro (Santa Rosa) via FW800
     
  2. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #2
    Sounds like the drive is faulty, I would return it under warranty and get a replacement
     
  3. neoserver macrumors 6502

    Joined:
    Apr 24, 2003
    #3
    I'd agree. Hearing a clicking sound while trying to read something is never a good thing. Its a sign that the drive is having issues.
     

Share This Page