Is this a software or hardware issue?

Discussion in 'iPhone' started by ClemTiger0408, Jun 25, 2009.

  1. ClemTiger0408 macrumors 6502

    Joined:
    Jun 30, 2007
    #1
    I got the iPhone 3GS on Saturday. This is my third iPhone so I am very familiar with the device.

    Since I got the 3GS every now and again, the screen becomes unresponsive to touch. Like, I might slide the screen over one and the screen won't do anything. The only thing that will make it work again is if I lock and unlock, which works every time.

    I didn't have 3.0 till I got the 3GS so I wasn't sure if this was a software issue with 3.0 or the hardware on my new phone.

    My concern is that I cannot repeat this issue on command so even if I take it to the Apple store there is no way I could prove to them the issue.
     
  2. TSX macrumors 68030

    TSX

    Joined:
    Oct 1, 2008
    Location:
    Texas
    #2
    I'm guessing software, some people claim it's buggy. Just restore and see if that helps.
     
  3. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #3
    i had this exact smae issue sometimes i couldnt slide to answer calls or click on icons.

    i just finished a restore and i set it up as a new phone so i am waiting to see if this changes anything.

    if it doesnt im screwed cause i bought the iphone outright for 811$ and Rogers doesnt refund items over 600$

    ill let you know what i find
     
  4. blueturf macrumors member

    Joined:
    Nov 25, 2008
  5. TSX macrumors 68030

    TSX

    Joined:
    Oct 1, 2008
    Location:
    Texas
    #5

    I'm sure apple will replace it if your having trouble.
     
  6. ClemTiger0408 thread starter macrumors 6502

    Joined:
    Jun 30, 2007
    #6
    Ok, then it sounds like a 3.0 issue and not a hardware issue.

    If that is the case then I have confidence that Apple will resolve the issue (eventually).
     
  7. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #7
    I had this issue on the 3G before OS 3.0, but since upgrading to OS 3.0 have not seen the problem again.
     
  8. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #8
    so after my restore i noticed i was still getting this bug, but i also noticed that lightly taping the phone on another object causes it to become responsive again.

    i wonder what this means
     
  9. kmt88 macrumors newbie

    Joined:
    Jun 25, 2009
    Location:
    Oregon
    #9
    This happened on my 1st gen iphone quite a bit, usually when I was receiving a call and once or twice so far on my 3gs.
     
  10. JohnFa macrumors regular

    Joined:
    Jun 12, 2009
    #10
    This sounds more like it's something wrong with the touch screen. I would get it replace if I were you, if it doesn't get solved with a restore.
     

Share This Page