Is this battery life normal?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dougeefresh, May 3, 2011.

  1. dougeefresh macrumors newbie

    Joined:
    May 3, 2011
    #1
    I just got an iPhone 4 from VZ and my batter has been draining faster than I thought it would. I have the following:

    Push - On
    WiFi - On
    BT - On but not connected to anything
    Location - On but no app is running
    Brightness - at 50% mark with Auto Brightness OFF (I had it on until just now to see if that was the culprit)
    OS - 4.2.7 (latest available for VZ iPhone)

    My phone has been on for 3 hours and I surfed for about 15 mins. Battery at 49%. No calls were made.

    Here's the funny thing. I went to dinner and came back (about 1 hour) and the phone is warm to the touch (it was sitting in my basement office which is substantially cooler). Now I remember that the phone has always been warm to the touch no matter how long it's been sitting untouched.

    I went through 3 charge cycle so far. This can't be normal? Is it defective? :(
     
  2. DeChrii macrumors member

    Joined:
    Mar 9, 2011
    #2
    hmm thats odd, my verizon white iphone 4 has a usage of 2 hours 20minutes and standby of 14 hours 32 minutes so a total of 16 hours 52 minutes and still at 60%.

    notification - on
    wifi - on
    3g - on
    brightness - 50% auto on
    (edit) just checked how many apps open and i have 20 open

    bring it in for an exchange or contact apple
     
  3. dougeefresh, May 3, 2011
    Last edited: May 3, 2011

    dougeefresh thread starter macrumors newbie

    Joined:
    May 3, 2011
    #3
    Wow, that was a fast reply! Thanks!
    There is something definitely wrong but I just can't put my finger on it.
    Now the usage time is at 3:30 and battery is at 38%.
     
  4. dougeefresh thread starter macrumors newbie

    Joined:
    May 3, 2011
    #4
    I figured out the cause and thought I would share for others who may be suffering from similar problems.

    It all came down to Exchange server's push service. I disabled everything and slowly turned on other services.

    So far, I have the following ON:

    - Find My Iphone (push)
    - 2 Gmail accounts (fetching every 30 mins)
    - Exchange account (calendar only although email with manual setting doesn't seem to affect the battery life)
    - Bluetooth
    - WiFi
    - Location service
    - Brightness at default (50% mark with Auto ON)

    My phone has been on for about 26 hours and at 24 hour mark, the battery was at 54%, and now 51%. Looks like I can comfortable get 2 days use out of it finally!
     

Share This Page