Is this just Lion or has it always been this way...? Question!

Discussion in 'Mac OS X Lion (10.7)' started by mloffa, Aug 9, 2011.

  1. mloffa macrumors 6502a

    mloffa

    Joined:
    Jul 13, 2009
    #1
    Okay I just noticed something today and I can't remember if it was the same in snow leopard and such but lets say you want to type the same letter a bunch of times, you'd press and hold - right? Well it doesn't work. Is that only on PC's? I honestly can't remember if that worked on SL. I know it's kind of silly but I like to do that sometimes in photoshop for whatever reason and just realized it didn't work.

    :eek:
     
  2. merrickdrfc macrumors 6502

    merrickdrfc

    Joined:
    Jan 8, 2011
    Location:
    Berlin
    #2
    Its the autocorrect feature in Lion that Apple took from iOS, rather annoying IMO
     
  3. mloffa thread starter macrumors 6502a

    mloffa

    Joined:
    Jul 13, 2009
    #3
    Yeah, I'm not really liking that feature too much. Not a huge deal, though.
     
  4. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #4
    It does too work, just hold a little longer.

    aaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

    Just typed that by holding down the "a" key, and I'm running Lion.
     
  5. mloffa thread starter macrumors 6502a

    mloffa

    Joined:
    Jul 13, 2009
    #5
    After about 30 seconds, I realized you weren't serious. ;):D
     
  6. scottsjack macrumors 68000

    Joined:
    Aug 25, 2010
    Location:
    Arizona
    #6
    Yes it's true, the folks at Apple seem to think that either everyone is working on an iPad or that everyone would rather be working on an iPad. Mac OS is become a tablet OS piece by piece.
     
  7. lewis82 macrumors 68000

    lewis82

    Joined:
    Aug 26, 2009
    Location:
    Totalitarian Republic of Northlandia
    #7
    I don't own Lion yet but I'm pretty sure I read that you can change a preference somewhere. ;)
     
  8. tkermit, Aug 9, 2011
    Last edited: Aug 9, 2011

    tkermit macrumors 68040

    tkermit

    Joined:
    Feb 20, 2004
    #8
    Type a letter, hold down Shift, press ←, release Shift, press ⌘-C, hold down ⌘-V, release whenever.


    *yaaaaaaaaaaaaaaaaaaaaaaaawn* [​IMG]
     
  9. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #9
    I'm amused by all the people complaining along with the OP. The issue the OP is experiencing is due to one of 3 possible things: an issue specific to the OP's set up the Mac, a setting in System Preferences preventing repeat, or a lack of patience on the OP's end.

    It does work just fine, both in Photoshop and out of it. Don't know what the big deal is.
     
  10. blastoboy1000 macrumors newbie

    Joined:
    Aug 7, 2011
    #10
    If you want to disable it, you can run this terminal command:
    Code:
    defaults write -g ApplePressAndHoldEnabled -bool false
    switch false to true to re-enable the accent picker thing.
     
  11. podsorcerer09 macrumors regular

    Joined:
    Sep 9, 2008
    #11
    Or it's possible that the folks at Apple don't see the need for over-repeated characters. Seriously the only people who type like that are 10 year old girls that add extra "y"s onto the ends of words. People continue to complain about the "loss" of this "feature" but I don't quite understand where you would use it. That being said it's likely that some people might want to view alternative characters without opening up the character picker window.
     
  12. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #12
    Non repeating keys are the default behavior of Lion.

    No kidding. Personally I think it's about time there is an easy way to get alternate accents without having to remember the option+key combo nonsense.
     

Share This Page