Is this normal? Video Included

Discussion in 'iMac' started by alksion, Nov 22, 2013.

  1. alksion macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #1
    I just received my LaCie 2big Quadra USB3.0 RAID external. In excitement, I obviously began to set it up. When I plugged in the power, I noticed it hanging toward the side rather than being securely fastened. I found this odd, but plugged in everything regardless.

    It turned on fine and connected to my iMac without any problems. I turned it off to readjust some cords and I noticed how loose the I/O board really was once removing the USB3 cord.

    Does anyone know if this is normal or can confirm that has one of their own?

    This video is an example of my issue. Yeah I know it's portrait, everyone's favorite!

    http://www.youtube.com/watch?v=Q8ocszNQ4_Q&feature=youtu.be
     
  2. 2Turbo macrumors 6502

    2Turbo

    Joined:
    Feb 18, 2011
    #2
    I don't have one, but that doesn't seem right bro.
     
  3. alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #3
    I know! What the hell right? Sorry, I'm just a bit pissed. I paid good money for this and it already seems to be made poorly right out of the box. I do live in Los Angeles and this item was shipped from New York. It is possible something came loose during the process.

    I think I will try to initiate an exchange with Adorama, if I get a second one like this, well that will decide poor workmanship over bad shipping.

    I might even just upgrade to the thunderbolt one while I am at it!
     
  4. IA64 macrumors 6502

    Joined:
    Nov 8, 2013
    #4
    I have the same unit and it's rock solid. This is not absolutely not normal.
     
  5. alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #5
    Thank you for the confirmation. I will certainly be putting an exchange through on Monday here. I knew something wasn't right!

    What do you think about exchanging it for the thunderbolt series?
     
  6. Arfdog macrumors 6502

    Joined:
    Jan 25, 2013
    #6
    What about you just tighten the bolts that hold it in.
     
  7. alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #7
    I looked at those, but wasn't sure if they connected to the main board. Are you sure that they do? Also, they have security pins, which I'll have to borrow some security bits from my friend if that's the case.
     

Share This Page