Is this what happens to Windows machines?

Discussion in 'macOS' started by mcdj, Sep 9, 2009.

  1. mcdj macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #1
    I was browsing the NY Times website and was rather shocked to see a large banner ad for "$49 Cartier watches". I clicked the link for kicks. Safari hiccupped a bit. The site loaded. It was obviously a place selling fakes.

    Just now, for an unrelated reason, I was looking at my Console logs and noticed this...

    9/9/09 11:09:38 PM Automator Runner[614] Error while processing arguments
    9/9/09 11:09:43 PM Automator Runner[614] No application name for definition file at path: /Library/Automator/Office.definition
    9/9/09 11:09:43 PM Automator Runner[614] The action “Add Attachments to Entourage Messages” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:43 PM Automator Runner[614] The action “Close Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Create New Entourage Mail Message” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Delete Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Export Entourage Contacts” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Forward Entourage Mail Messages” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Get Selected Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Get Selected Text from Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Get Text from Entourage Mail Messages” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Import Contacts into Entourage” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Insert Content into Entourage Mail Messages” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Mark Entourage Mail Message as a To Do Item” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:44 PM Automator Runner[614] The action “Open Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Paste Clipboard Content into Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Print Entourage Messages” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Quit Entourage” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Reply to Entourage Mail Messages” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Save Entourage Items as Files” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Save Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Save Files Attached to Entourage Mail Messages” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Search Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Send Outgoing Entourage Mail Messages” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Set Category of Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Set Entourage Contact Properties” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Set Project for Entourage Items” could not be loaded because the application “Microsoft Entourage” was not found.
    9/9/09 11:09:45 PM Automator Runner[614] The action “Apply SQL” could not be loaded because the application “Xcode” was not found.
    9/9/09 11:09:46 PM Automator Runner[614] The action “Build Xcode Project” could not be loaded because the application “Xcode” was not found.
    9/9/09 11:09:46 PM Automator Runner[614] The action “Convert CSV to SQL” could not be loaded because the application “Xcode” was not found.
    9/9/09 11:09:46 PM Automator Runner[614] The action “Create Package” could not be loaded because the application “PackageMaker” was not found.
    9/9/09 11:09:46 PM Automator Runner[614] The action “CVS Add” could not be loaded because the file “/usr/bin/cvs” was not found.
    9/9/09 11:09:46 PM Automator Runner[614] The action “CVS Checkout” could not be loaded because the file “/usr/bin/cvs” was not found.
    9/9/09 11:09:46 PM Automator Runner[614] The action “CVS Commit” could not be loaded because the file “/usr/bin/cvs” was not found.
    9/9/09 11:09:46 PM Automator Runner[614] The action “CVS Update” could not be loaded because the file “/usr/bin/cvs” was not found.
    9/9/09 11:09:47 PM Automator Runner[614] The action “Execute SQL” could not be loaded because the application “Xcode” was not found.
    9/9/09 11:09:48 PM Automator Runner[614] The action “Initiate Remote Broadcast” could not be loaded because the application “QuickTime Broadcaster” was not found.

    The time stamp on these would be right when I clicked on the fake watches link.

    Remind me never to click any web links on any PC ever.
     
  2. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
  3. mcdj thread starter macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #3
    I'm not trying to be an arrogant fanboy here. I'm actually a little wobbled by this. I mean, clicking a banner ad that sets your machine marching off to do some evil programmer's bidding is bad enough, but to see it in detail is disturbing. And even more disturbing is that it happened via the NY Times website, a place you shouldn't have to worry about clicking ads on.
     
  4. broken-chaos macrumors regular

    broken-chaos

    Joined:
    Sep 2, 2009
    Location:
    Toronto, Ontario
    #4
    Do you have MS Office installed? There's some discussion on Apple's boards that suggests this may be related to MS Office, notably the updater, and that the timing could have just been coincidental (or not related to a specific action, at least).

    http://discussions.apple.com/thread.jspa?threadID=1774417

    ...Wait a second, you're the same person as who posted this previously on Macrumors, and on the Apple discussion boards - most notably, the only person I can find any record of this ever happening to.

    Have you done a clean install since last posting this about 10 months ago?
     
  5. donbenjy macrumors 6502

    Joined:
    Oct 15, 2008
    #5
    Did you inform the NY Times about this? I'm sure they wouldn't want any spyware/spamming links from their site. Even if they aren't responsible for the ads and use something like adsense, they could still pass it on to whoever syndicates their adverts.
     
  6. mcdj thread starter macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #6
    I did, and they wrote back thanking me for bringing it to their attention. They said the ads should not be up much longer.

    I do have office installed, but some of those console entries still seem mighty fishy to me.
     
  7. mcdj thread starter macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #7
    Wow, what a moron. I totally forgot I posted that. I thought the messages looked strangely familiar! I never did get a resolution to that, though I never saw it again, until now. It is a clean install BTW...
     
  8. broken-chaos macrumors regular

    broken-chaos

    Joined:
    Sep 2, 2009
    Location:
    Toronto, Ontario
    #8
    If it is a clean install, it strikes me as unlikely that this is a malware problem, unless there's some fishy program you've installed both times. A security hole of this sort of magnitude (random execution of Automator actions) would seem like it would be patched very quickly - or at least noticed by more than a single person.

    Can you check through the appropriate logs in Console.app for any other occurrences of these log messages? It may be an automated process related to MS Office - if it is, then it's likely to show up in some sort of semi-regular pattern.
     

Share This Page