iShockX Dual Shock Feedback gamepad install

Discussion in 'Mac and PC Games' started by Defender90CA, Apr 28, 2010.

  1. Defender90CA macrumors newbie

    Joined:
    Apr 28, 2010
    #1
    Hey all! Longtime listener, first-time caller...

    I just got an iShockX Dual Shock Feedback gamepad as a b'day present but am having trouble getting it up and running. I downloaded the driver from the Macally website and got that installed; there's an iShockX Manager in my System Folder, and if I open that it recognizes the gamepad being there, as I can test keys and see the Manager reflecting my actions.

    I don't know how to get my games to recognize it, however. I've tried Call of Duty 4: Modern Warfare and Halo. I also tried the Quake Live site, just in case. When I select controls or settings and try and change the keys for moving, combat, etc., the games will let me go in as if to edit, but nothing I do on the gamepad registers... like the game's control panel isn't aware of the gamepad.

    The Macally website support is pretty much bare-bones, and only mentions help getting the driver installed, which I seem to have done, since it's in my System Prefs folder. Other than that, it suggests consulting instructions for individual games to see how to get set up. I couldn't find any info in my COD4 instructions, so before I email Aspyr for help, I thought I would see if I could get some ideas here.

    Thanks in advance for any assistance you can offer!

    Oh yeah, I am running OSX 10.6.3 and have played all of these games many times, so I know the games themselves work with my system.
     
  2. Defender90CA thread starter macrumors newbie

    Joined:
    Apr 28, 2010
    #2
    COD4 explanation

    "Hello,

    Thank you for contacting Aspyr Technical Support!

    Call of Duty 4: Modern Warfare for Mac only supports keyboard and mouse controls.

    Feel free to contact us with any further issues or concerns.

    Thank you,

    Aspyr Technical Support"
     
  3. citizenbfk macrumors newbie

    Joined:
    May 6, 2010
    Location:
    Rural, Arizona, USA
    #3
    Working OK for me.

    Out of the games you mentioned, I got it to work with a Halo Demo.

    It works with X-Plane 9, RC Helicopter Stimulator, StuntMania, HyperTank and FlatOut 2 on my computer, OS 10.6.3

    What's been The Hassle, though, is that not all software is equal about explaining how to setup and/or edit the Controller Options.

    But, on all I've mentioned, the iShockX is recognized. On another software demo I got, Colin McCally Rally, the 'rumble,' also works.

    My RC Helicopter stimulator demo the hardest to get right. Adjusting the sensitivity of the controls important. Trim. Software cooefficient. Stuff I had no idea about but had to figure out by Google and trial and error (and reinstalling software and starting from scratch.

    All software I've mentioned has Demos, so you can download them for free and try it out.:cool:
     
  4. Defender90CA thread starter macrumors newbie

    Joined:
    Apr 28, 2010
    #4
    I have the Halo Demo and it does recognize the controller, but am having trouble getting the keys/options set. I'll keep trying. Thanks for your feedback!
     
  5. RAT1 macrumors newbie

    Joined:
    May 20, 2010
    #5
    Macally iShockx

    Defender-

    I just installed the iShock drivers on my 10.6+ OS, and, got the results you described.

    However, at the end of the install, I had 6 or so error messages about various files not being installed.

    Did you or anyone else note this?
     
  6. Defender90CA thread starter macrumors newbie

    Joined:
    Apr 28, 2010
    #6
    Install worked fine

    No, installing the drivers on my Mac worked fine. See if you have a folder for the iShock now in your System Prefs. If it's there, open it and see if your actions on the gamepad are recognized. If they are, then it prolly was installed properly. If not, I'd do a re-install and try again. Good luck!
     
  7. dmarcus48 macrumors newbie

    Joined:
    Jul 25, 2010
    Location:
    Central NJ
    #7
    same problem

    I just got a IShockX. I'm using it on a MacBook Pro 15" (new one intel based) running os 10.6.4. I downloaded the drivers from macally, iShockX_OSXInstaller_IntelBased.dmg). The drivers installs fine, but once it's done and the mac restarts the iShockX manager doesn't recognize the device. I've tried to install it with the gamepad plugged in, and not plugged in and get
    the same result. Any ideas???
     

Share This Page