iSight broken on iMac?

Discussion in 'iMac' started by shipdestroyer, Aug 10, 2007.

  1. shipdestroyer macrumors 6502

    Joined:
    Jun 5, 2007
    Location:
    New Hampshire
    #1
    I picked up a 20" mirror iMac last night. It's great, except Photo Booth asks for me to plug in a camera or close another app using the iSight. I don't have the mirror widget installed. Tried resetting SMC, PRAM, software update, repairing permissions, logging in as a new user. It doesn't show up in Profiler under any USB bus. Basically, I tried everything short of reinstalling OS X, which doesn't seem like it'll help.

    Hardware problem? Should I be able to get the iMac replaced? I don't want to let the Genius Bar take it from me--they manhandled my Macbook last time I left it. :(
     
  2. Mollemand macrumors regular

    Joined:
    Aug 1, 2007
    #2
    That's seven years of bad luck right there, breaking a mirror, that is. ;)
     
  3. Nick12QB macrumors member

    Joined:
    Mar 27, 2007
    #3
    same problem

    ship destroyer, i'm having the exact same issue on my new 24". How was yours resolved, I'd really rather not bring it in for service if there is an easier fix.
     
  4. oduinnin macrumors regular

    Joined:
    Aug 3, 2007
    Location:
    Planet Earth
    #4
    If the hardware is OK, it should show up under "USB High-Speed Bus" in the profiler panel.
     
  5. Nick12QB macrumors member

    Joined:
    Mar 27, 2007
    #5
    yes..

    yes, and it doesn't. I have done everything (SMC, PRAM.. different users, all of it and hasn't come up)
     
  6. jimsoff macrumors member

    Joined:
    Aug 8, 2007
    #6
    I'd call apple tech support. They might have you try a few things. Then if they can't help, bring it in for repair or exchange it. (Depending on if you've become attached to it or not, in my case, I'd want to have it repaired.)
     
  7. astewart macrumors member

    Joined:
    Sep 12, 2006
    Location:
    Charlottetown
    #7
    Just a long shot, just to rule out that it isn't a software problem.
    Open up the terminal and type "top".
    Make sure there are no running processes in the background that might be using the Built-in iSight, or the HS USB Bus.
    If there is nothing noticable then quite possibly it could be a hardware problem..
     
  8. heshiegreshie macrumors newbie

    Joined:
    Sep 8, 2007
    #8
    same problem

    I had the same problem with a brand new 20" iMac. The iSight camera was working beautifully until I went and installed the drivers and software that came with the hp photosmart printer that was an added "bonus" of purchasing the system with an educational discount. Since doing so, the iSight is not recognized, and doesn't show up in the system profiler under usb devices.

    I went through the same attempts to resolve the issue to no avail. No one with customer service online, by phone, at the genius bar or hp customer service (absolutely terrible btw) had an idea on how to fix this short of a total teardown and reinstall of os x.

    Does anyone have any idea on how to install new drivers for a built in isight camera to os x? I'm a recent switcher and don't have the language to frame the question appropriately. It seems that if I was able to do a software reinstall of the camera, it would set things right again. I'd rather not have to backup and reinstall if possible.

    Thanks for any and all help.

    h
     

Share This Page