iSight (built-in) on MacBook not working

Discussion in 'Mac Basics and Help' started by Eric1117, Feb 26, 2008.

  1. Eric1117 macrumors newbie

    Joined:
    Feb 26, 2008
    #1
    I purchased a MacBook (Black) in September of 2007. Everything worked fine. The beginning of this week I opened up Photobooth and the screen was black. I couldn't take any pictures. Also video chat in iChat did not work as well.

    The iSight camera is detected in the System Profiler and the green LED light does turn on when I open photobooth or iChat. I ran a hardware test and no issues were found. I reset the SMU and the PRAM and all that. I contacted AppleCare and did all the troubleshooting again. I also started a test account to see if it was a user issue and it was not. AppleCare determined it was either a software/driver issue.

    I was wondering if anyone had any information about this kind of problem? I'd rather not reinstall the Mac OS 10.5 on my computer. Is there a way to reinstall the iSight driver? Thanks for any help.
     
  2. MarkMS macrumors 6502a

    Joined:
    Aug 30, 2006
    #2
    Did they have you boot into Safe Mode? Had something happen to me a year ago on a relatively new iMac. Booted into safe mode, then restarted and the iSight was working again.

    Hope this helps.
     
  3. Eric1117 thread starter macrumors newbie

    Joined:
    Feb 26, 2008
    #3
    I just did a boot into Safe Mode and then restarted. iSight still not working.

    AppleCare told me it's probably a driver that needs to be replaced. Anyone know how to do this? I searched on my install disc last night for two hours and couldn't find the driver needed. It's called "QuickTimeUSBVDCDigitizer.component" and I found it on my HD but couldn't find it on the Install disc. It's under System/Library/Quicktime on my HD.
     
  4. MarkMS macrumors 6502a

    Joined:
    Aug 30, 2006
    #4
    Only two other things I can offer is to look into Pacifist. Just use pacifist to extract and replace the QuickTimeUSBVDCDIgitizer.component file from your install DVD. I don't know where it would be located, but hopefully someone else, on here, knows. Seems that you've tried searching in the install discs, but I don't know if you used Pacifist.


    Second thing is to look over this Apple Discussions thread. Look specifically at EZ Jim's advice. He has a bunch of tips that may shed some light into what may have caused the iSight to stop working.

    I really wish I could be more helpful.
     

Share This Page