iSight in Vista

Discussion in 'Windows, Linux & Others on the Mac' started by dclnmurray, Jul 1, 2007.

  1. dclnmurray macrumors newbie

    Joined:
    Jul 1, 2007
    #1
    Hi all

    Have setup Vista with BC 1.3 on the 17" MBP and all is fine except for the iSight camera which is listed with yellow exclamation mark and informs me no drivers installed..

    Had a look on the 1.3 CD and ran the appleisightinstaller and after a prompt to allow it then doesn't do anything, well not that I can see.

    I removed the device and then selected detect hardware and now come up as unknown device and tried to install driver again.

    Anyone have any idea's to get this device working?

    cheers

    Dave
     
  2. M@lew macrumors 68000

    M@lew

    Joined:
    Nov 18, 2006
    Location:
    Melbourne, Australia
    #2
    Did you install the Boot Camp tools/drivers properly?
     
  3. cml91 macrumors newbie

    Joined:
    Oct 13, 2006
    Location:
    Vancouver BC Canada
    #3
    yes i have the same problem too and i have all the drivers up to date and everything is working except the isight
     
  4. dclnmurray thread starter macrumors newbie

    Joined:
    Jul 1, 2007
    #4
    No go after trying another method.

    I expanded the appleisightinstall on another computer and the result is a number of files so the file is not corrupt.

    File list
    DPInst App
    DPInst XML
    iSight (Security Catalog)
    iSight (Setup inf)
    iSightCI.dll
    iSightFT.sys
    iSightUP.sys
    WdfCoInstaller01005.dll

    Tried browsing to these files to update driver through device manager but no good.


    Tried to install the inf file directly and get an error "The INF file you selected does not support this method of installation"

    At a loss.

    Is there anyone that owns a Macbook Pro (recent) and have the isight working?

    Dave
     
  5. kwood macrumors 6502a

    kwood

    Joined:
    Jun 26, 2006
    Location:
    In the Great White North.
    #5
    Try ripping the driver CD again. I had to burn like 5 before I finally got a good working one. (it's what happens when you buy cheap CDs).
     
  6. cocacola5373 macrumors newbie

    Joined:
    Sep 8, 2006
    #6
    I too am having the exact same problem although in Windows XP SP2. I had never had that problem with the older versions of Bootcamp and the older generations of MB and MBPs. I have burned the drivers disk over 5 times using 3 different kinds of cds and still the same problem. My hunch is that it has something to do with the updated isight (1.3MP) on the SR machines. Can somebody please confirm if they are having the same problems with Bootcamp 1.3 with pre Santa Rosa machines? I have a 17" MBP SR and having these problems.
     

Share This Page