iSight not working/not recognized

Discussion in 'Mac Accessories' started by tycheong, Feb 6, 2009.

  1. tycheong macrumors member

    Joined:
    Jul 31, 2008
    #1
    i was on gmail one day, and then i realized that the video chat icon wasnt showing and only the mic works. i opened up photobooth and the iSight in my unibody mbp isn't recognized. also, any app that involves the iSight cant detect it
    it worked fine before i installed Xp, but i dont think Xp is the problem?
    any ideas? suggestions? solutions?
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    If it doesn't work in any application its quite possible its a hardware issue. I doubt it has anything to do with the XP installation. Some things to try: Check the USB section under Hardware in the System Profiler. Look for an item named USB High-Speed Bus and see if it lists the iSight under it. If it doesn't, you could try an SMC reset. Hope you have AppleCare or are within the 1 year limited warranty if repairs are needed.
     
  3. tycheong thread starter macrumors member

    Joined:
    Jul 31, 2008
    #3
    Under System Profiler I do see two USH High-Speed Buses. so its there...but not working?

    and yes, i am still under the 1 year warrenty.........
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    The USB High-Speed Bus can show up, but if you click on the triangle to the left of the words, is the iSight camera listed? If it says Vendor-Specific device or nothing at all, try the reset before bringing it to a service provider to have it checked out.
     
  5. tycheong thread starter macrumors member

    Joined:
    Jul 31, 2008
    #5
    there is no triangle to the left of the USB High-Speed Buses
     
  6. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    Time to bring it in for servicing. A connector may have gotten loose at some point. Under the limited warranty there shouldn't be a charge unless they find some evidence of accidental damage.
     
  7. tycheong thread starter macrumors member

    Joined:
    Jul 31, 2008
    #7
    i've had my mbp since december and the iSight has been working fine until last week
    any chance i might've done something?

    the SMC reset resets the hardware power management functions...
    what exactly does that mean?

    i'll take it to the apple store if nothing works but does anyone have any ideas???
     

Share This Page