iSight not working (SOLVED. Check if you are using a usb-powered hub. Design fault?)

Discussion in 'MacBook Pro' started by hajime, Sep 10, 2011.

  1. hajime, Sep 10, 2011
    Last edited: Sep 11, 2011

    hajime macrumors 68030

    Joined:
    Jul 23, 2007
    #1
    Hello. I have a MBP 17" 2010. iSight was working fine for a year. Recently, whenever I launch Photo Booth, I get a black screen. I tried iChat but under audio/video, it also says either that there is no camera connected to this computer or another application is using it. The LED indicator is off all the time. Does that mean the iSight camera is dead? Could it be a software issue due to 10.6.8? I upgraded it when it was available. Can't recall if the iSight problem started before or after I upgraded to 10.6.8. Thanks.
     
  2. Aldaris macrumors 65816

    Aldaris

    Joined:
    Sep 7, 2004
    Location:
    Salt Lake
    #2
    Try resetting the SMC or PMU, I had mine act similar a while back, system profiler wouldn't even recognize it.
     
  3. hajime thread starter macrumors 68030

    Joined:
    Jul 23, 2007
    #3
    Thanks.

    Do you mean Control+Option+Shift+Power On ? I tried it but it still does not work. There is even no LED on top of the LCD screen. Internal iSight is being listed under USB high speed bus.
     
  4. hajime thread starter macrumors 68030

    Joined:
    Jul 23, 2007
    #4
    I checked many postings and they often refer to the reset of the SMC. It does not work for me.

    I noticed that the internal iSight is listed as a usb device. Out of curiosity, I unplugged two devices connected to the external usb hub. The problem is solved (avoided?) immediately. The iSight LED is on and I can see myself under Photo Booth.

    It seems that by using a usb-powered hub and connecting a few devices to it (tv tuner, usb flash memory, usb key for software, logitech mouse receiver), there was no enough power to turn on the iSight camera. Isn't this a design fault? Can anybody try this on their MBP to verify the situation?
     
  5. djessee macrumors newbie

    Joined:
    May 25, 2012
    #5
    This was ABSOLUTELY my problem. What was strange is that the iSight worked just fine in FaceTime and iChat, just not Photo Booth. As soon as I unplugged my USB hub, all was well. Thank you so much!!!
     

Share This Page