Isight on Imac not working..

Discussion in 'Mac Basics and Help' started by Peruvian, May 20, 2009.

  1. Peruvian macrumors regular

    Peruvian

    Joined:
    Jun 10, 2006
    Location:
    U.K.
    #1
    Ok, My isight is non responsive on my imac.

    When i open photobooth, all i get is the camera logo with a line going thru it... When i open ichat, it says no camera is attached... There is no green light, in system profiler under USB TREE, the isight is not even recognized....

    I have reset pram, smu, did an archive and reinstall... But no luck, is there anything else I should try, I want to sort it myself, calling apple is a last resort for me...

    thanks P....

    Imac 3.06 ghz intel core 2 duo (2008)
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    I'll save you the trouble of calling Apple. If it's not software, they are not going to be able to fix it for you by calling in. If you have already reinstalled the OS, and done those resets, all that is left is for a technician to take the unit apart and replace the camera board, bezel, or cabling to the logic board. I don't know how UK service providers work but in the US you can request onsite for desktop systems instead of having to carry them in-store.
     
  3. Peruvian thread starter macrumors regular

    Peruvian

    Joined:
    Jun 10, 2006
    Location:
    U.K.
    #3
    Thanks for the reply.... Your answer was what I was trying to avoid, but I guess there is no other way to fix a hardware problem.....

    P....
     

Share This Page