Issue connecting PS3 Controller to OSX 10.8

Discussion in 'OS X Mountain Lion (10.8)' started by BaurPowr, Aug 11, 2012.

  1. BaurPowr macrumors newbie

    Aug 11, 2012
    I've looked and looked all over for a guide that works and all I keep finding is the same ol' "Plug in USB connector, enter 0000 s passcode...." etc. However i can't even get to that step apparently.

    Whenever I plug my USB cord into my computer and then into my ps3 controller, the controller comes up as something odd like: ee-7f-00-00-00-00 and then when i hover over it and try to connect to it nothing happens.

    I've looked and looked all over for a fix to this and I can't find something? Is it the drivers? I can't figure out for the life of me what's wrong. :confused:

    Currently running Mountain Lion 10.8 if that helps...
  2. k12g3 macrumors member

    Jun 12, 2009
    I have used mine with FIFA 12 on Mountain Lion. I used a program called "GamePad Companion" to connect it. Try that!

    Good luck!
  3. BaurPowr thread starter macrumors newbie

    Aug 11, 2012
    I'm looking for a way to play with my ps3 controller through bluetooth, not through he USB connection. I have a wired logitech controller if i wanted to do that. :/
  4. optimus prime macrumors regular

    Jul 9, 2007
  5. asknone9 macrumors newbie

    Oct 21, 2009
    I'm having the same problem as BaurPowr ever since I installed 10.8.
  6. -pete- macrumors member

    Apr 20, 2011
    Same problem, it was working fine in Lion and now it seems to be broken, anyone know of a fix?
  7. Rossagues macrumors regular


    Aug 12, 2012
    Gamepad Companion 3.1 is on the App Store so you its easy to update and use too. So id go with k12g3 too!
  8. Starfox macrumors 6502


    Apr 7, 2011
    Keep it connected for a while before disconnecting, that sometimes happens when the battery is low.
  9. gurnted macrumors newbie

    Sep 23, 2012
    Simple way to get it to connect., and avoid pin request...add it's address to in HIDDevices array.

    As for getting it to STAY connected....F.i.I.K

    Our best bet is probably to try begging the people working on PSMove API for a little help.
  10. ivoruest macrumors 6502


    Jul 12, 2010
    This solved all of my problems!!! Thank you!

    Every one else, this is recommended.
  11. ajluchesa macrumors newbie

    Oct 20, 2012
    Im having a similar problem! Please note that I currently have OS X 10.8 (Mountain Lion) and I am trying to pair my Dualshock 3 controller.

    I open bluetooth (from system preferences) turn on bluetooth (from the top menu bar) and hit the PS button on my controller. This causes the controller to connect. A popup appears asking me for a passcode in order to pair so I type in 0000 (the default passcode for bluetooth devices) and hit enter. After a few seconds the popup disappears but the controller is no longer connected! A half a second after that the controller reconnects and the same popup appears asking to pair again :confused:

    Any ideas/ help?
  12. ABuNeNe macrumors newbie

    Nov 1, 2012
    I'm having the same problem here. It's keeping disappearing after I did the "Add to Favorite" and/or "Update services". I tried different passcodes, "0000", "oooo", "xxxx", ..., and they all give me the same behaviour.

    Any help?
  13. kirdes macrumors newbie

    Jul 3, 2011
    You need to restart macos after you added the controller to the favourites and during the controller is still connected.

    This helps for me.

Share This Page