Issue Creating a 2nd Partition on Fusion Drive

Discussion in 'Mac mini' started by jedib0p, Dec 1, 2012.

  1. jedib0p macrumors member

    Sep 15, 2006
    I was wondering if anyone else has had issues creating a 2nd partition on the fusion drive. When I choose the size the partition ends up being far larger than the size I had selected. (Example: I choose 80GB for the partition and when the resize operation is completed it is 270GB instead.)

    I've tried partitioning the drive in OS X and while booted into the recovery partition.
  2. MatthewAMEL macrumors 6502


    Oct 23, 2007
    Orlando, FL
    What are you using to attempt to create the partition?

    Currently, only the version of Boot Camp Assistant and Disk Utility that ship with the new Mini or iMac support Fusion Drive in the GUI.
  3. jedib0p thread starter macrumors member

    Sep 15, 2006
    I have a 2012 Mac Mini and I'm using Disk Utility GUI.
  4. scottyd1119 macrumors newbie

    Oct 18, 2012
    I tried this last night as well using the gui version of disk utility. The only thing that it would allow me to do was create a new partition that was half of the original. I had no control over the size. I tried this and basically ended up with half the space available. The new partition I created for all intense and purposes evaporated into thin air. I went into terminal and used command diskutil list. It showed that I had a second partition. I didn't go any further, not feeling comfortable running any commands to get it to show. I ended up just splitting the core storage and creating two drives out of the fusion. I like the idea of the fusion drive but was hoping to partition the 1tb drive to allow some control over where files were stored, i.e. wanted to put all my pictures, movies, music, etc on a separate volume because they don't need speed increase of the ssd.

    I would love to see if anyone does figure out a way to partition the platter drive because I might re-fuse the drives and go that route.
  5. jedib0p thread starter macrumors member

    Sep 15, 2006
    I found that when creating the 2nd partition you are not able to enter a size numerically but you can however drag the space between the 2 partitions to decrease/increase its size.

    The problem for me is that the size shown after dragging is much much different than what is created when applying the new partition.
  6. scottyd1119 macrumors newbie

    Oct 18, 2012
    Did your new partition show up as a separate volume and were you able to access it?
  7. jedib0p thread starter macrumors member

    Sep 15, 2006
    Yes. I had no problem creating the new volume and could access it fine. The only issue is it isn't sizing correctly. I want to make a partition that is ~150GB but even choosing (by dragging) a partition size of 65GB (the smallest i could select) when the process is complete the partition would be 270GB.

    I created and deleted the 2nd partition using various sizes several times and the result was always the same. The created partition would end up being ~200GB larger than what I selected.
  8. MJL, Dec 2, 2012
    Last edited: Dec 2, 2012

    MJL macrumors 6502a

    Jun 25, 2011
    Enquiring mind likes to know:

    This 65 Gb / 270 Gb partition: is that the resized original partition or is it the new partition?

    How large is your SSD?

    Can it be that the whole SSD forms the Fusion partition with a small part of the HHD and that the other partition is only a part of the HDD without a part of the SSD?


    edit: I suppose goes a long way to answering the questions I have.
  9. jedib0p thread starter macrumors member

    Sep 15, 2006
    This is an Apple official Fusion Drive. Not a DIY. It has a Samsung 830 128GB SSD and a Hitachi 1TB 5400rpm HDD.

    I've taken a few screenshots to show what's going on. As you can see in the picture the 2nd partition is showing 67.3GB. All other space is shown as being allocated to the primary Fusion partition.

    Here's an output of the Log file shown what actually happens when applying it as shown.

    2012-12-01 15:41:49 -0400: Disk Utility started.
    2012-12-01 15:42:25 -0400: Preparing to partition disk: “APPLE HDD HTS541010A9E662 Media”
    2012-12-01 15:42:26 -0400: Checking prerequisites for resizing Logical-Physical volume stack
    2012-12-01 15:42:26 -0400: Shrinking Logical-Physical volume stack
    2012-12-01 15:42:26 -0400: Checking file system
    2012-12-01 15:42:26 -0400: Performing live verification.
    2012-12-01 15:42:26 -0400: Checking Journaled HFS Plus volume.
    2012-12-01 15:42:26 -0400: Checking extents overflow file.
    2012-12-01 15:42:26 -0400: Checking catalog file.
    2012-12-01 15:42:51 -0400: Checking multi-linked files.
    2012-12-01 15:42:51 -0400: Checking catalog hierarchy.
    2012-12-01 15:42:51 -0400: Checking extended attributes file.
    2012-12-01 15:42:51 -0400: Checking volume bitmap.
    2012-12-01 15:42:51 -0400: Checking volume information.
    2012-12-01 15:42:51 -0400: The volume Fusion HD appears to be OK.
    2012-12-01 15:42:51 -0400: Shrinking file system
    2012-12-01 15:42:51 -0400: Shrinking Logical Volume
    2012-12-01 15:42:51 -0400: Resizing Core Storage Logical Volume structures
    2012-12-01 15:42:52 -0400: Resized Core Storage Logical Volume to 837076029440 bytes
    2012-12-01 15:42:52 -0400: Shrinking Core Storage Physical Volume from 999345127424 to 724594659328 bytes
    2012-12-01 15:42:52 -0400: Shrinking Core Storage data structures
    2012-12-01 15:42:52 -0400: Resizing Core Storage Physical Volume structures
    2012-12-01 15:42:54 -0400: Resized Core Storage Physical Volume to 724594659328 bytes
    2012-12-01 15:42:54 -0400: Copying booter
    2012-12-01 15:43:17 -0400: Shrinking partition for Physical Volume and adding new partitions
    2012-12-01 15:43:17 -0400: Modifying partition map
    2012-12-01 15:43:22 -0400: Initialized /dev/rdisk1s4 as a 256 GB HFS Plus volume with a 24576k journal
    2012-12-01 15:43:22 -0400: Mounting disk
    2012-12-01 15:43:22 -0400: Partition complete.
    2012-12-01 15:43:22 -0400: 
    So that 67.3GB volume becomes 256GB. I haven't been able to make it any smaller than that. The primary volume loses the appropriate amount of space and the total amount of storage over the 2 volumes is still 1.12TB.

    Attached Files:

  10. chrise2 macrumors 6502

    Sep 17, 2012
    I thought you were only supposed to use the Boot Camp assistant to create the partition on a Fusion drive. Maybe delete that partition and try again?
  11. jedib0p thread starter macrumors member

    Sep 15, 2006
    In case anyone is curious I worked around this issue using command line tools while booted in to the Recovery Partition.

    I started with a single Fusion Drive partition (aside from Recovery HD and EFI partitions) and then used the command:

    diskutil cs resizeStack
    It allows you to perform a shrink (or grow) operation on the LVG, specify which PV is reduced and partition the newly created space in 1 or several partitions.

    This allowed me to specify the size I wanted for my 2nd partition and actually get the correct size.
  12. cingularpat macrumors newbie

    Jan 24, 2008

    How did you use this command? I tried it using the UUID of my Fusion drive and it says it's invalid. Can you shed some light on the proper verbiage for the command??

  13. Fishrrman macrumors G5


    Feb 20, 2009
    If I start out with a fusion drive (128gb SSD + 1tb HDD), can I do the following?

    1. Manually "un-fuse" the two drives (yes, I know this can be done), then...

    2. PARTITION the 1tb HDD drive into, say, 4 separate partitions (256gb each), then...

    3. RE-fuse ONE of the partitions with the SSD drive.

    The results should appear on the desktop as:
    - fusion drive (SSD + HDD)
    - another partition
    - another partition
    - another partition
    (4 disk icons, total)

  14. jedib0p thread starter macrumors member

    Sep 15, 2006
    Here's the output from the diskutil command:

    diskutil coreStorage resizeStack lvUUID [pvUUID] size
    [part1Format part1Name part1Size part2Format part2Name part2Size
    part3Format part3Name part3Size ...]

    the lvUUID I think was the last number that comes up when you do a "diskutil cs list" (it may have been the LVG UUID but if you put the wrong one it will just give an error and you can change it to the correct one). The pvUUID is an optional command to specify which physical disk is reduced when the command is carried out. This is useful to insure the space is resized on the HDD rather than the SSD.

    In my case my original Fusion Drive was 1.12TB and I wanted to create a partition that was 120GB on the HDD (turning the fusion into roughly 1.0TB). I basically compared the sizes from the diskutil list command to determine what the before and after sizes should be.

    Here's a screenshot to show you what numbers I used.

    Obviously you would need to use your own UUIDs but here's what my command looked like:

    diskutil cs resizeStack B76211F4-4A5B-44FB-AC5B-8CCE361CADA2 CC0F89BF-4A19-4442-B273-933AF6D772C1 991G jhfs+ Media 120G
    991G is the size I want my Fusion Drive to be post operation.
    "jfhs+ Media 120G" specifies I want to create a 120GB journaled HFS+ volume named Media.

    I'm going from memory here but hopefully that is clear enough for you.

    Attached Files:

  15. jedib0p thread starter macrumors member

    Sep 15, 2006
    1. You shouldn't need to "un-fuse" the Fusion Drive. You can use the same command that I specified above.

    Determine the sizes of partitions that are present on the HDD currently and the sizes of the new partitions you want to add.

    So for example you currently have the corestorage volume and a recovery HD volume. You want to create 3 new partitions each 150GB (450GB total removed from the corestorage volume) in size on the HDD. Use the command as such:

    diskutil cs resizeStack lvUUID pvUUID 660G jhfs+ Volume1name 150G jhfs+ Volume2name 150G jhfs+ Volume3name 150G
    660G is a rough guess at the size of the Fusion volume (~540GB on HDD + 120G SSD) Adjust the sizes to your specific needs.
  16. cingularpat macrumors newbie

    Jan 24, 2008
    It Worked!

    jedib0p, that worked perfectly! Thank you for explaining!!
  17. iKenny303 macrumors newbie

    Oct 16, 2011
    Did this erase the data on the original (fusion) partition

    jedib0p, if the fusion partition already has Mt Lion and user data on it, is it erased by this process of creating the 2nd partition?
  18. jedib0p thread starter macrumors member

    Sep 15, 2006
    The resizeStack command is non-destructive so no, your data will not be erased. Of course, you should always backup just in case.
  19. cingularpat macrumors newbie

    Jan 24, 2008
    While my resize procedure worked great, I was doing this for the purpose of making a Bootcamp partition. Unfortunately, Windows just wouldn't install on it. I'm thinking there's too many partitions on the HDD for Windows to be happy.
  20. jedib0p thread starter macrumors member

    Sep 15, 2006
    Did you format as jhfs+ or fat32 or ntfs? It would need to be a compatible volume for you to install windows.

    Any reason you didn't just use the boot camp assistant?
  21. cingularpat macrumors newbie

    Jan 24, 2008
    Formatted as FAT32 during the resize, and then let the Windows Installer reformat as NTFS. I tried the Bootcamp assistant, but it wouldn't recognize my flash drive with the Windows Installer on it, even though it boots fine when holding Alt down during startup. So I could never get to the actual re-formatting of the drive.
  22. marc.garcia macrumors regular

    Jul 26, 2010
    I bow to you. I've followed your indications and I must say that I'm almost there. Thanks a million for sharing your knowledge. I've been with Apple Support on the phone for nearly 2h across different days, and they seem to be clueless as to how Disk Utility created a 650GB partition when I actually requested 200GB. After providing log files and stuff, the only thing they were able to say is "you must backup your data and we will guide you through the process of reformatting" which, of course, implies that if, for some reason, my TimeMachine backup is corrupted (I know it is rare), I'm in trouble. Of course, they couldn't even confirm that by reformatting my drive I would be able to set the right size for my partition... all in all great.

    Let's get down to the point... I wanted to create a 200GB partition for storing our family iPhoto Library (which needs to live on a partition on which permissions are ignored). I run
    diskutility cs resizeStack lvUUID pvUUID 920G jhfs+ "Macintosh HD2" 200G 
    and this is what things look like on my end once that action has been performed:

    macminiserver:~ marc$ diskutil list
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *121.3 GB   disk0
       1:                        EFI                         209.7 MB   disk0s1
       2:          Apple_CoreStorage                         121.0 GB   disk0s2
       3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *1.0 TB     disk1
       1:                        EFI                         209.7 MB   disk1s1
       2:          Apple_CoreStorage                         819.0 GB   disk1s2
       3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
       4:                  Apple_HFS Macintosh HD2           [B][COLOR="red"]180.2 GB   disk1s4[/COLOR][/B]
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:                  Apple_HFS Macintosh HD           *920.0 GB   disk2
    and this is the output of diskutility cs list

    macminiserver:~ marc$ diskutil cs list
    CoreStorage logical volume groups (1 found)
    +-- Logical Volume Group 506ECF85-DC01-4079-AE62-1263D4C2AA1E
        Name:         Macintosh HD
        Status:       Online
        Size:         [B][COLOR="Red"]939988852736 B (940.0 GB)[/COLOR][/B]
        [COLOR="red"][B]Free Space:   11481481216 B (11.5 GB)[/B][/COLOR]
        +-< Physical Volume 5C7EA77D-2F0C-4141-A5B7-3A3CDE2D4A7C
        |   ----------------------------------------------------
        |   Index:    0
        |   Disk:     disk0s2
        |   Status:   Online
        |   Size:     120988852224 B (121.0 GB)
        +-< Physical Volume F74CEADE-2968-4D7C-82F9-D0E217C52099
        |   ----------------------------------------------------
        |   Index:    1
        |   Disk:     disk1s2
        |   Status:   Online
        |   Size:     819000000512 B (819.0 GB)
        +-> Logical Volume Family F90FD8E6-737D-41C4-A389-C2BF95A57483
            Encryption Status:       Unlocked
            Encryption Type:         None
            Conversion Status:       NoConversion
            Conversion Direction:    -none-
            Has Encrypted Extents:   No
            Fully Secure:            No
            Passphrase Required:     No
            +-> Logical Volume 9700F74E-832F-4214-962C-037D44085D5D
                Disk:               disk2
                Status:             Online
                [COLOR="red"][B]Size (Total):       920000000000 B (920.0 GB)[/B][/COLOR]
                Size (Converted):   -none-
                Revertible:         No
                LV Name:            Macintosh HD
                Volume Name:        Macintosh HD
                Content Hint:       Apple_HFS
    Can you possibly help me out here? 20GB seem to be missing on the new partition, and they seem to be stuck up in the LVG, right? Could you also think of a way to recover those annoying 11GB too?

    I really thank you in advance beforehand.

  23. jedib0p thread starter macrumors member

    Sep 15, 2006
    I wish I could give you a detailed response but unfortunately I don't have access to my Mac for the next 5 weeks and can't re familiarize myself with the commands.

    If you haven't started moving data to your "Macintosh HD2" I would suggest deleting the volume and attempting to recover your lost space on the single cs volume first.

    Then recreate the separate volume using the resizestack command.

    Alternatively you could try experimenting with the other cs commands like resizevolume. Absolutely make sure to have a backup before attempting this.
  24. marc.garcia macrumors regular

    Jul 26, 2010
    I've already started copying some data but I can easily remove it. I decided to duplicate my data and monitor the whole system for the firsts days, so no problem in emptying the new partitiong. I know you don't have your PC around, but could you possibly give some indications in order to achieve what you suggest?

    As I said, I followed your indications yesterday, and I started off with a wrong sized partition of 650GB. By using several "diskutility cs" commands, I managed to swallow up the space mostly; those 11GB I referred to earlier appeared at this point... that's why I'm asking for directions because I have the feeling I pulled the volume but not quite to the edge or something.

    sure, no problem. Once I manage to get back all the space, I could definitely try that although I'm surprised that 20GB appear to be hiding somewhere I can't figure out.

    I think this is one of the commands I tried at the very beginning yesterday while I was attempting to get rid of that useless partition.

    yes, I have a TimeMachine backup on a external HDD and another backup on my NAS. Even with two backups, I'm wary at all this.
  25. jedib0p thread starter macrumors member

    Sep 15, 2006
    Are you using an official fusion drive? If so, remove the second volume using disk utility app (GUI. Not the command line version). You may need to boot the recoveryHD or a USB mountain lion disk to do this. I believe all the disk space should be recovered on completion.

    Check using
    diskutil cs list
    There shouldn't be any free space and your fusion drive should be its original size.

    Provided the above is true proceed to the next step.

    diskutil list
    Discover the size of the apple_corestorage on disk1. It is from this size that you will reduce to create a 2nd volume. (At this moment disk0s2 and disk1s2 should be adding up to the total of the LVG)

    So, for example, if your fusion drive is 1000G (120G SSD and 880G HD) and you want a 2nd 200G volume your numbers should be Fusion Drive= 800G (120G SSD and 680G HD)

    So once you've determined the sizes use the resize command as follows:

    diskutil cs resizestack lvUUID pvUUIDofdisk1s2 fusionsize jhfs+ "Macintosh HD2" 200G
    In order to ensure the operation uses all the available space I would suggest using a larger fusion drive size than you had calculated in the command. It will give you an error if there isn't enough space. Just reduce the value by 1 until the command runs. For me my final fusion size was 991G and I started at 997G until the command ran.

    I hope this is legible. It's really hard writing a post on an iPhone.

Share This Page