Issue opening alsmost any file

Discussion in 'OS X Yosemite (10.10)' started by RovakX, Nov 3, 2015.

  1. RovakX, Nov 3, 2015
    Last edited: Nov 4, 2015

    RovakX macrumors newbie

    Joined:
    Nov 3, 2015
    #1
    [​IMG]

    Here's my situation:
    I'm getting this notification when I try to open any file acquired over the internet.
    This image was the first time i encountered the problem, but ever since any file i download, I can't open.
    I tried Microsoft office files, PDF, Zip files, some video's, mp3, aac, Jpg, ...
    I tried transfer over gmail (via Mail app), facebook, directly from a website.
    I tried opening a file with different apps eg word, textedit.
    All with the same result.
    When I download the same file on another device, then transfer it via USB stick, I managed to open a word document and a jpg.
    Any files created on this machine open just fine.
    an .avi movie downloaded with torrents do open for some reason (I played it with VLC, opening music files with VLC doesn't work though)
    Apps open just fine

    The problem started yesterday evening, after transferring this .docx file via email.
    Other files, witch I opened yesterday morning, and I can't open anymore.
    Another weird thing is that I can view most documents like pictures in finder, (by pressing spacebar when a file is selected) but when i then try to open them, it wont work.
    (I also tried turning my firewall off before downloading a file, nothing helps)

    Please someone help me!
    I have a time machine backup from a few weeks ago, if all else fails.

    Macbook Pro 15" Early 2011
    OSX Yosemite 10.10.5
    2GHz Intel Core i7
    16GB 1333MHz DDR3
    Mackintosh HD
    AMD Radeon HD 6490M 256MB
    Safari 9.0.1

    Anything else you need to know?

    Edit: I found a way to open files, by opening the app first ant then clickinf file > open file > ....
    So I was thinking maybe a problem with Finder? but then why only downloaded files?
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Could be squirrely security issues. As a test, change System Preferences>Security & Privacy>Allow apps downloaded from: to "Anywhere" and see if you can open the documents.
     

Share This Page