Issue setting up port forwarding?

Discussion in 'Mac Basics and Help' started by Sirnot1, Jan 23, 2012.

  1. Sirnot1 macrumors newbie

    Joined:
    Jan 2, 2012
    #1
    Hi guys, I have spent all day trying to set up port forwarding so my web server can be accessible from the internet. I have a D-Link 524 router and after following all the directions for setting up port forwarding, surprisingly it didn't work. I have already set up a static local ip for my mac server (192.168.0.100) and have already set up all the port forwarding. For some reason, under the "Status" category in the D-Link's settings, it says that my public ip provided from my isp is 192.168.250.170, which I am sure it is obviously not, for whatismyipaddress.com tells me that it is 70.103.20.179. To try to fix this, I tried to change my dynamic WAN ip to static and then change the provided public ip to the 70.103.20.179 one. Unfortunately, this did not work because the ISP Gateway Address was obviously a different domain than the public ip.

    So, what do you guys think is wrong? How can I fix this?

    By the way I use XAMPP if it matters.
     
  2. Sirnot1 thread starter macrumors newbie

    Joined:
    Jan 2, 2012
    #2
    Update: I have find out that my problem is because of a Double NAS configuration, so I tried tovfix this by port fording all ports from my modem to my router (from which there the router would port forward to my computer). The problem is that when I tried to browse to the modem ip, no configuration page came up. Is it possible that my modem may not have a configuration page? If so, how will I fix this entire mess? :confused:
     
  3. Sirnot1 thread starter macrumors newbie

    Joined:
    Jan 2, 2012
  4. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #4
    So you have a cable modem and a router, is that right? I don't understand your statement about forwarding all ports from the modem to the router, and then again from the router to your computer. It doesn't work that way. The modem connects to the router and, as far as the modem is concerned, that is the only device it sees. All traffic that enters the modem goes to the router, without any special configuring. Then if you want to forward port 80, for example, to your computer, you configure that in the router's software.

    You said something about the problem being a double NAS configuration. You do mean NAT, right? What double NAT condition are you referring to?

    I think you are probably changing too many settings when you probably only needed to change one or two settings. You may want to reset your router's settings back to how everything originally was and start over. If your router thinks your IP is 192.168.x.x then either you're misunderstanding something or you shouldn't have an Internet connection.

    Let me ask you this: How did you diagnose that port forwarding wasn't working when you very first configured the router? Could port forwarding have been working but Apache was misconfigured? Could everything have been working but your firewall was blocking the port? Is your router on the most recent firmware version?
     

Share This Page