Issue with 3GS GPS...please help!

Discussion in 'iPhone' started by chase71320, Jul 4, 2009.

  1. chase71320 macrumors newbie

    Joined:
    Dec 14, 2008
    #1
    I've had the 3GS since launch day (purchased from apple.com) and initially everything worked fine. I would open the Maps app and tap "Find Me," and the dot would place my location within a few feet...exactly as it should. Now, no matter where I am (outside on a clear day, inside, etc) my iPhone does not find me. It simply triangulates the cell tower signal and gives me a pulsating circle with a berth of a mile. My previous iPhone (first generation) could do the exact same thing. I've contacted Apple and been patronizingly told that the GPS chip is not "a professional GPS" and that it is only an app. While I understand that a few different factors could cause a blockage in the signal between chip and satellite, I also understand that when standing outside on a clear day with full 3G signal, there's no real excuse for the GPS not to work. To test this, I held my brother's 3GS in one hand and mine in a another, and pressed the "Find Me" key on both. My brother's connected to the satellite and placed us exactly where we were. Mine triangulated the signal and said I was a mile away. All I want is to have a device that I paid for to operate as it should. I don't want to get a new phone if I don't have to, but I need to be advised on the best course of action based on what I've already tried. Thanks for reading.
     
  2. slpdLoad macrumors 6502a

    slpdLoad

    Joined:
    Jun 10, 2009
    #2
    I'd take yours and your brother's into an Apple store. If his works and yours doesn't right in front of the genius, you should be able to get it replaced.

    I asume you've restarted the phone, and done a backup and restore?
     
  3. wr1020 macrumors regular

    Joined:
    Jun 10, 2009
    #3
    Mine is kind of similar, i'll be at my house and click on the current location icon and it'll be about 4-5 blocks away from my house. Sometimes i'll have to quit maps and start it back up and again hit the current location icon and it'll be where i'm at. It's sometimes dead accurate and other times way off. I tried resetting the network settings and it worked for a little bit but it's back to being not too accurate.
     

Share This Page