Issue with compact flash card in FAT 32 macbook pro and OSX Mavericks - error -36

Discussion in 'OS X Mavericks (10.9)' started by cesarez, Aug 29, 2014.

  1. cesarez macrumors newbie

    Joined:
    Aug 29, 2014
    #1
    Hi all,
    I have a MBP 1H2012 with OSX 10.9.4 (13E28).
    I am trying to read a compact flash card formatted in fat 32 from a Canon 5D mark II.

    I can not copy or open files from the flash card, whereas i can copy files to the flash card. Before updating to mavericks it was working, but i am not sure this is the issue.

    When i try to open or copy I get error -36 and the disk unmounts.

    Actually with a MBP early 2011, same OSX, same version i can read and write.

    I can not format the card in other formats than FAT 32 because the 5D reads only that format.

    I've extensively searched the web but it seems that the only related solution is linked to dot-files cleaning, which i tried and did not work. Moreover given i can read and write on the other MBP with the same version of OSX, i suppose it might be a a problem related to some conflict in this specific machine rather than a generalized software issue?

    I already repaired permissions and tried an alternative file manager to finder


    Thanks a lot in advance for all your answers
    C
     
  2. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #2
    This may sound silly, but have you tried hooking your card reader to another USB port? I had a weird issue once where the hub I was using eventually developed an issue, and there were one or two ports out of seven that would corrupt all of the images on my card if the card reader were plugged into them. I didn't receive an error message (other than that the files were corrupted), but it showed that the individual USB ports can make a potentially big difference.

    Another possible suggestion: you said that you tried repairing permissions. Did you verify your disk (the hard drive, not the CF card)? Do that just to ensure that the error isn't a hardware/filesystem issue on your main hard drive.

    Another consideration is on the camera-side. I shoot with an Olympus and don't know if this applies to Canon, but how are you wiping your CF cards? In theory there are three ways to do it: with the computer; quickly with the camera ("erase all"); and a bit slower with the camera (reformat). Olympus users generally said that reformatting with the camera was the best option to go with. If you erase with the computer then it might cause problems with the camera's ability to read and write to the card; if you do a quick erase with the camera but never reformat, then eventually the CF card may become corrupted. I don't know if that advice is still applicable (or if there was ever any truth to it to begin with), but I followed it and never had an issue until my USB hub developed issues.
     
  3. cesarez thread starter macrumors newbie

    Joined:
    Aug 29, 2014
    #3
    Hi,
    thanks for your reply!

    I did try all of the 2 ports available on the MBP.

    The permissions were repaired on my OS hard disk actually, because (and I come to the 3rd question) i reformatted several times the card using the camera (which also for canon is the best option) so i thought it did not make sense to repair permissions on the card.

    Thanks anyways
    Any other suggestion?

    thanks!
    c
     

Share This Page