Issue with Excel 2011 scatter plot

Discussion in 'Mac Apps and Mac App Store' started by elixir, Dec 22, 2011.

  1. elixir macrumors newbie

    Joined:
    Dec 22, 2011
    #1
    Hi guys

    I just bought my first MacBook, and I'm slowly adjusting to the platform.

    It's all great, but I have a really big issue in Excel 2011, when trying to create a simple scatter chart.

    When I try to plot in the x and y values I get the following message:
    "The formula you typed contains an error"

    I have never experienced this in Excel 2010, and I have NO idea why I get this error?

    Can someone please help me? I have an exam coming up soon, and I have to be able to make these charts. :(
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    There is built-in help in Excel for troubleshooting formulas. That's a good first step.
    Sorry, I don't do people's homework for them. The point of the exam is to make sure you learned how to do the work, not to prove you learned how to get someone on a forum to do it for you.
     
  3. elixir thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #3
    I tried that, and googled the h*** out of it without luck... this is my last resort :(

    This has nothing to do with people doing my homework.
    As I said, making simple scatter charts with 5 x and y values never posed a problem for me in Excel 2010. :(
     
  4. elixir thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #4
    Well, it works if I copy the values to a new workbook, and create the chart from there.....
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    Then why don't you do that? Before, you were typing in the x, y pair in a single cell. Your x and y values should be in separate columns.
     
  6. elixir thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #6
    The x and y values are in separate columns to begin with, so that is not the issue. I simply don't have time to copy it to a new workbook, cause it's for a time restricted written exam.

    Let me try to rephrase my issue, with more details:

    There are 5 y-values in column B and 5 x-values in column C. I click on the "Charts" ribbon and select a scatter chart.

    I then press "Add", name the chart and select the x values. And here is where my troubles begin.

    As soon as I hit enter after having selected my x values, I get a message saying "The formula you typed contains an error".

    These x and y values are made from formulas, so I assumed there might be an issue there. But if I copy and paste these numbers as values only, the same error message comes up again.

    Only if I open a new workbook, and copy the values to that, does the problem go away.

    The only way I can create a graph in the original workbook, is if I first mark all the cells, and press "Charts" --> "scatter chart". But the problem here is, that I have to add more plots later on.. and the same issue returns, as I have to select the data :(
     
  7. elixir thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #7
    I'm pretty sure this is an Excel 2011 issue, since i just tried opening the same document on a windows machine, and I had no issue selecting the data.. :(
     
  8. elixir thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #8
    I think I've figured out the problem here.

    What I did was create a new sheet in the same workbook, and copy the content into this new sheet. I then tried creating the chart, by using select data, and it worked!!

    Then i tried renaming the newly created sheet from "sheet1" to "U3.1", which is the name of the assignment I'm doing. After renaming it, the problem started coming back. So I renamed it again to "U 3.1" (with space in between). And voila the problem went away again...

    So I assume it's some kind of bug in Excel 2011.
     

Share This Page