Issue with FCPX Exporting

Discussion in 'Digital Video' started by teezy, Aug 19, 2015.

  1. teezy macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
    #1
    What's up, peeps! I'm having a strange problem with exporting footage in FCPX. Now, the footage is .MOV DV (720x480). I don't know if it's actually anamorphic or not because I didn't film it nor perform the initial edits and am just doing small corrections (cuts, dubs, etc), but FCPX "detected" it as 720x480 DV anamorphic. Frame rate is picked up as 29.97i. The unedited footage looks perfectly fine outside of FCPX (QuickTime, VLC) but after I've done edits and exported them, every other few frames is blurry and then back to normal again. This is with every one of the 12 videos in this project, and with some of the videos I only added a small 5-second text layer in the beginning.

    My export settings (before I realized the resolution thing)
    • Master File (default)
    • Format: Computer
    • Video Codec: H.264 Better Quality
    • Resolution: 640x480
    Imported the footage into After Effects in hopes to make sure that the resolution was definitely 720x480, and it was. So then I redid an export in FCPX.
    Export settings:
    • Master File (default)
    • Format: Mastering (Video and Audio)
    • Video Codec: DV // Apple ProRes 422 is still in process...
    • Resolution: 720x480
    The weird thing is that the only selectable resolution when I used the "Computer" format (previous settings) was 640x480. The 3 or 4 others were strange (like 960x845 or something) and were greyed out.
    Nonetheless, I have attached screenshots to show you exactly what goes on with the videos... every one of them. Blurry... not blurry... blurry... not blurry.


    Screen Shot 2015-08-13 at 6.22.35 PM.png Screen Shot 2015-08-13 at 6.22.50 PM.png
     
  2. fabulousrice macrumors newbie

    fabulousrice

    Joined:
    Aug 19, 2015
    Location:
    Berkeley
    #2


    This seems to be a problem with interlacing.
    Did you deinterlace the files before editing them, or during exportation?
     
  3. teezy thread starter macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
    #3
    That might be the issue... I didn't deinterlace the files at all, all I did was import them and start editing. I used Final Cut's automatically-detected settings (which I presumed looked "right" so I went with it and readjusted accordingly). I exported this same video @ 29.97i a little while ago and didn't notice any jumping from blurry to not blurry, but the video overall isn't as sharp as the original...
     
  4. fabulousrice macrumors newbie

    fabulousrice

    Joined:
    Aug 19, 2015
    Location:
    Berkeley
    #4

    Always make sure you understand every little setting about the video files you will edit, particularly the interlacing which is very tricky!
    In Premiere Pro (which I recommend using, over FCP), this is easy to read in the file settings and fix...
     
  5. teezy thread starter macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
    #5
    You're right. I've never worked with DV footage before, which explains why I'm so lost, lol.
     
  6. teezy thread starter macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
    #6
    So I tried exporting this same video (again, using "Master File") as a ProRess 422, using 8 different resolution settings:
    • 720x480 DV @ 29.97i
    • 720x480 DV @ 29.97p
    • 720x480 Anamorphic @ 29.97i
    • 720x480 Anamorphic @ 29.97p
    • 720x486 @ 29.97i
    • 720x486 @ 29.97p
    • 720x486 Anamorphic @ 29.97i
    • 720x486 Anamorphic @ 29.97p
    ... and IIRC (because I kept overwriting the file instead of saving separate ones) out of all of these, 720x486 Anamorphic @ 29.97i solved the in-and-out blurry problem most efficiently, but is still not as clear as the original file, which I'm not understanding. I'm not compressing or encoding the file from Final Cut since I'm using "Master File", so why does the output suffer such a major quality loss? I would say I'd start from a new empty event, but that's literally what I've done weeks ago with this exact video and have come out with the same results. o_O I'd hate to have to start from scratch, regardless of whether or not I use Premiere Pro or Final Cut once again (I honestly prefer Final Cut because it's what I use most often, I'm not very familiar with any of Adobe's video programs as of yet) because these videos were edited on site for an architecture firm... if only I could copy and paste from Final Cut to Premiere, lol
     
  7. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #7
    On one or two DV projects we were unable to fix interlace issues with Premiere Pro, the results from FCPX were better. We ended up running the original video though either Handbrake or Bigasoft ProRes (I forget which one) before importing into FCPX for editing and that seemed to resolve most of the issues.
     
  8. teezy thread starter macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
    #8
    Huh. Great idea. I'll try that. What settings should I use? I'm not looking to compress the videos for editing, because they will be sent off on a drive for encoding after everything is edited. My order is to provide the really big master files... *eye roll*
     
  9. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #9
    I'll have to go back and check our notes... it may take awhile to find them. I think for handbrake we just used the "high profile" defaults. For Bigasoft, it was one of the built in prores defaults. We didn't tinker too much. One of the videos had numerous defects. Bigasoft support suggested we set async = 1 and that resolved most. Some we just had to cut around. There may be other apps that de-interlace or pre-process just as well, we just used what was handy.

    With any of these pre-processors there is video manipulation and sometimes some compression.

    Just a suggestion.
     
  10. steve123 macrumors regular

    Joined:
    Aug 26, 2007
    #10
    Have you tried using MPEGStreamClip?
     
  11. steve123 macrumors regular

    Joined:
    Aug 26, 2007
    #11
    Also, you might try using Compressor to preprocess the DV source material to ProRes. You will get better results.
     
  12. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #12
    Oh yeah, compressor is another one we used... but it seemed to be slow and didn't handle dropouts as well. Shouldn't be a problem with DV, however.. MPEGStreamClip was a waste of time in this case. I'm still looking for the set up notes. Its been a year since we did anything like this.
     
  13. steve123 macrumors regular

    Joined:
    Aug 26, 2007
    #13
    Yeah, deinterlacing can be a real difficult thing to do and get good results. As I remember, I think I got the best results with Compressor. It takes a while to run, especially if you enable optical flow.
     
  14. teezy thread starter macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
    #14
    Hey, guys

    I ran one of the unedited files through Premiere (I have CS6) without modifying any settings, and it came out with the same quality as the original, with no tears or random resolution jumps or whatever it's actually called. Only difference is that it was about ~50% of the file size (8.15gb vs 4.07gb), which is great.

    Another thing I noticed was that Premiere used a DVPRO50 output codec, instead of ProRes or "DV" like Final Cut gave me the option to...

    So I changed the codec to DV in Final Cut and got the same result, with every possible resolution and frame rate setting (29.97i/29.97p). I'm stuck...
     
  15. steve123 macrumors regular

    Joined:
    Aug 26, 2007
    #15
    Hmmm. Might want to file a bug report. Sounds like something weird is going on.

    You might try creating a new library and reimport the video. Maybe there is a messed up setting somewhere.
     
  16. teezy thread starter macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
    #16
    I'll do that. Do you think copy and pasting a timeline for one of the videos (there are 12 for this project) in a new project/event in the new library will put me in the same place?
     
  17. haysoos123 macrumors newbie

    Joined:
    Jun 2, 2008
    #17
    Are you using QuickTime 7 to look at the outputs? Make sure it's set to "high quality" when viewing. Not sure if it's the problem, just something to check.
     
  18. teezy thread starter macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
  19. teezy, Sep 5, 2015
    Last edited: Sep 5, 2015

    teezy thread starter macrumors member

    teezy

    Joined:
    Jul 18, 2012
    Location:
    Tri-State Area, USA
    #19
    So after reviewing the footage myself, I've come to realize that only 1 of the 12 videos has that issue (the one in the screenshots)... I don't know why, but I'm pretty sure it has something to do with that particular event in the library.

    All of the other videos look great, with the exception of two (including the one in the screenshots) that does this in-and-out junk. I've also found that I have a "_fixed" event for each of two original events in the library... not sure why but I think I've zeroed in on where the issue lies.

    Now I need to compare edits to ensure everything is the same in the original and "_fixed" events because I honestly don't recall why I made these "_fixed" events... (it's been almost 2 months).

    Edit: I think I get it now. The original two events are 640x480 and NOT DV. I reckon I made "_fixed" events so I could have the proper resolution (720x480) and the DV codec option for the project and export/render settings. Huh...... and all of the other projects are in DV 720x480 29.97i. I'm stumped again lol... Btw I did create a new library and consolidated and re-linked all of the media, so everything is clean and up-to-date...
     

Share This Page