issue with finder and external fat32 formatted drive - finder renames folders

Discussion in 'macOS' started by finger11, Aug 27, 2007.

  1. finger11 macrumors member

    Joined:
    Apr 11, 2007
    #1
    os x 10.4.10

    Hi all,
    I want to share an external drive with both my windows box and my mbp. I formatted it through os x choosing MS-DOS file system (FAT32). I then tried to create 1 folder (called 'topfolder') and 2 folders (called 'folder1' and 'folder2') within topfolder through finder. So far, so good. Then I tried to copy some files to folder1 from my internal. Suddenly, within topfolder, I see two folders both called folder2. According to finder, folder1 has disappeared or rather, been renamed.

    When I view topfolder through terminal, all is good, there is still 2 folders called folder1 and folder2. However, finder is way off, pretty much makes the drive useless if I want to use finder.

    Has anyone seen this before and have any tips? I really want to keep it in FAT32 as I'd rather not use MacFUSE (if I went NTFS).
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Did you initially create the folders with Terminal or Finder?
     
  3. finger11 thread starter macrumors member

    Joined:
    Apr 11, 2007
    #3
    created with finder
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Very strange. How old is the drive? Maybe use Disk Utility to quickly verify it.
     
  5. finger11 thread starter macrumors member

    Joined:
    Apr 11, 2007
    #5
    thanks for the reply madjew...

    i agree, it's very strange...and i know some folks reading this think i made a naming error or something but i assure you i didn't, i even reformatted the drive and gave it a 2nd go to confirm..

    drive is a brand new seagate 7200.10 320 gig in a owc mercury elite enclosure..

    i just restarted the drive (cycled the power on the enclosure) and all looks good so far however it makes me quite frightened at storing impt data on the drive...
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Yeah, it's pretty disconcerting. I believe you that you haven't just made a naming error, although that'd be reassuring if you had. Keep an eye on the drive with Disk Utility and make sure everything on it is kept somewhere else as backup too.
     
  7. RedCat macrumors newbie

    Joined:
    Sep 4, 2007
    #7
    Experiencing the same FAT32 issues

    Hi,

    just read the thread and can confirm that I have the same issue. Bought a new iMac in August 2007 and hooked up a Lacie ex hdd with 5 FAT32 partitions on it for dual Windows/OSX use. When I create a new folder on partition A it reads correctly, say DOCUMENTS1. When I create another folder after that, say DOCUMENTS2, it shows up correctly at first, but then DOCUMENTS1 all the sudden changes to DOCUMENTS2, and I have two identical folders sitting on the root level of partition A. It gets weirder. When I delete DOCUMENTS2 (the real one, second folder), the 'wonna-be' DOCUMENTS2 folder renames itself BACK to DOCUMENTS1 and sits there. When I now try to delete DOCUMENTS1, it doesn't let me and gives itself a new name along the lines of 'FOLDER 34-83-98', or similar.

    When I get home I will reformat to Apple native format and avoid data loss. When I felt the hdd at the time, it was really hot, and could have potentially caused the issue (don't know, however) When I started up the drive the next day, I was able to delete the weird folders successfully, but new folders would again show the same wacko behavior. So I am nervous now and will stop using FAT32 on OSX.

    Sounds like a finder + FAT32 issue to me. Any ideas anyone?:confused:
     
  8. klagermkii macrumors member

    Joined:
    Mar 15, 2007
    #8
    :mad:

    Had two folders (on FAT32) starting with the same first 9 letters... wanted to delete the one, and Finder decided to delete the other one instead! Can't pull it out of Trash because this same bug seems to mess up the process of moving it into Trash.

    Come on Apple, this is a really serious bug, sort it out!
     

Share This Page