Issue with graphic card NVIDIA Geforce GTX 96

Discussion in 'Mac Basics and Help' started by ginoraas, Apr 4, 2018.

  1. ginoraas macrumors newbie

    Joined:
    Apr 4, 2018
    #1
    Hi everyone,
    I got a problem (and related panic :)). I got a Mac Pro 4.1 early 2009 (El Capitain 10.11.6) with an NVIDIA Geforce GTX 960. Everything worked fine til the last Security Update 2018-002. After that every moving object on my screen is flickering and I can't work anymore. Another person installed the Geforce GTX 960 on my Mac, so I'm not able to figure out where is the problem.

    I searched for exaustive topic but I wasn't able to find the right one.

    I'm not an expert like most of you out there, I apologize in advance for that!

    What happened?
    It's a question of drives?
    Have I to unistall and re-install the graphic card?

    Many thanks for your time and help!
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
  3. ginoraas thread starter macrumors newbie

    Joined:
    Apr 4, 2018
    #3
    Thanks Satcomer, I followed all the instructions.
    I uninstalled the web driver and the CUDA driver, then I physically uninstalled and re-installed the GPU: no issues now with flickering moving objects or monitor problems.

    Now the problem are performances! All is very slow, I start Premiere Pro 2018 and it takes much more time than before, when the damned Security Update was not upgraded.

    Any suggestion? How can I go back to my previous setup and performance?

    Many thanks in advance to everyone!
     

Share This Page