Issue with hard drive and wifi

Discussion in 'OS X Yosemite (10.10)' started by had0ukenn, Jan 19, 2015.

  1. had0ukenn macrumors member

    Joined:
    Sep 1, 2013
    #1
    Mid 2012 - Macbook Pro - OS X Yosemite - 16 GB ram

    Initially my brothers macbook pro started to lag at start-up, then moving files to other folders wouldn't work, it would just give him some sort of error message. He was connected to wifi but then none of his browsers would be able to connect to the internet, he tried safari, chrome, and firefox, basically anything using internet would not be able to connect, even though other devices in the house were connecting fine to the internet. He tried restarting the macbook, trying to see maybe if it would fix the problem, but it showed some sort of debug text on the loading screen, after some time, he was able to somehow login. The problems didn't go away, he tried booting up in safe mode and it showed some sort of horizontal white lines on start up, saying it looked kinda glitchy.

    He took the macbook to the apple store and the tech did a wifi diagnostic, reset some of the start up preferences, he then tried restarting the computer but it was taking a long time. None of these things helped so the tech told him to go back home and back up the files and come back later on in the day.

    So my brother came to me, i tried backing up his stuff using time machine but it wouldn't recognize the external hard drive, after partitioning it (GUID) and erasing it properly. I tried unplugging it and plugging it back in but it wouldn't recognize the external device, it then gave me a message saying "Unapproved Caller SecurityAgent may only be invoked by Apple Software." I launched disk utilities to make sure the main hard drive was okay, by verifying the disk and all, it gave me the okay. I verified the disk permissions and repaired those as well for the hard drive (not external) just in case. I then restarted the macbook and it wouldn't start. So i booted the macbook in recovery mode, went into disk utilities and chose to verify the main hard drives disk again, it said it needed to be repaired, something about EPI partition, i repaired the disk but it wont boot up at all now. It just gets stuck on the start up screen, it wasn't even making the chiming sound, just showing the apple logo.

    After trying to boot up in safe mode to no avail, i then took out his hard drive, put it in an external enclosure and tried booting it up from there. It first recognized his name, but when i clicked on it, it wouldn't do anything. After doing this several times, i put his hard drive into my macbook and booted it up from there, it took me straight to a "reset password" menu. It keeps doing this. I tried putting the hard drive back into his macbook and it wouldn't even start up to the "reset password" menu. I also tried to put my HDD into his macbook to see if it works, and it booted up fine. However, my SSD wouldn't boot up from his macbook, it was showing the "flashing folder" icon, but my SSD was giving me trouble just a couple of days ago, it wasn't booting up from my computer either.

    Anyone know what i can do? I want to try and recover his files but disk utilities isn't even showing his disk space used. When i go into disk utilities the disk "Macintosh HD" is only showing two tabs; First Aid and Partition. The type it shows is "Logical Volume Group. The Disk status says "Online. It showing that Available is only 19 mb, even though he only used about 180 GB out of a 500Gb hard drive. The name of the partition is also "Macintosh HD," its showing the mount point as "not mounted" and format as "encrypted logical partition" with the capacity at 498GB. I feel like repairing the disk exacerbated the issue. Any ideas whats going on?

    Thanks and sorry for the long text.
     
  2. Xeridionix macrumors regular

    Joined:
    Jan 6, 2015
    #2
    I'm going to take a stab at this. The volume is encrypted by FileVault, which is likely why you're seeing the "Reset Password" prompt when connecting it to your MacBook. I'm not sure how you would go about disabling FileVault on the disk without destroying the data that's on it, but hopefully someone else can chime in with some more instructions and insight on that part of it.

    As for the whole Logical Volume Group thing, it's because Yosemite partitions the drive as whats known as Core Storage, which is used as part of FileVault now. Don't pay too much attention to the free space as that's just showing what is available for the whole group, if you were able to mount the "Macintosh HD" partition you'd be able to see the correct amount of free space and what not.

    My guess is that the issue may be caused by a faulty Serial ATA cable from what you've described. Are you able to successfully boot your SSD using the enclosure on his MacBook?
     
  3. had0ukenn thread starter macrumors member

    Joined:
    Sep 1, 2013
    #3
    Yes, I'm able to boot the SSD perfectly from an external enclosure, but that is my SSD and not my brothers.


    I just went to disk utilities again, went to partition and clicked "unlock" because it was showing as locked for some reason, after entering the password it now shows the correct files/folders, and available space etc. Any idea whats going on?
     
  4. Xeridionix macrumors regular

    Joined:
    Jan 6, 2015
    #4
    By doing that you've unlocked the encryption on the FileVault enabled volume, which then gives you access to all of the files on the disk. If you're currently booted into OS X, grab another external disk and start copying all of his data so he can have his unit serviced at the Apple store.

    Like I said before, chances are it's a bad SATA cable based on what you've described. That would cause issues with the drive being able to read/write data successfully and cause the issues that you're seeing with the machine, and also explains why booting from your SSD using the enclosure works fine.
     
  5. had0ukenn thread starter macrumors member

    Joined:
    Sep 1, 2013
    #5

    Thanks you for your reply. I was able to boot into the OS and am currently backing up using time machine. Any idea why the disk locked itself up like that?

    You're most likely right about the sata cable, thanks again!
     
  6. Xeridionix macrumors regular

    Joined:
    Jan 6, 2015
    #6
    I'm not entirely sure to be honest, I'm not sure if FileVault encryption on a drive is able to lock a user out after a certain amount of failed attempts or not. It is of course designed to prevent such scenarios (for example someone steals a password protected computer, takes out hard disk to try to gain access to personal data.)

    Either way I'm glad to hear you're able to get everything backed up, let us know how things turn out when his computer gets serviced. Have a good one. :)
     
  7. had0ukenn thread starter macrumors member

    Joined:
    Sep 1, 2013
    #7
    Thanks for all the help, and will do =)
     

Share This Page