Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

atlchamp

macrumors 68020
Original poster
Jun 19, 2012
2,056
1,245
Atlanta
Hey guys so ever since I updated to iOS 12 I have been having an issue where when I leave my WIFI enabled home, the LTE connection never takes over even though it says LTE at the top, i get a message saying that my phone is not connected to a data network. I am on Verizon, using an X. Airplane mode does not work and the only way to get it to work is by restarting the phone completely.

Anyone else have this issue/fix?
 
  • Like
Reactions: wza360

DblHelix

macrumors 6502a
Mar 19, 2009
768
631
nobody has this issue? Ive reset network and all settings. nobody?

Not quite, but I have had the same issue for several years. At home I am connected to wifi and have a weak signal so drops to either 3g or more often 1x. When I leave my house it will never reconnect to LTE I have to turn on airplane mode then turn it off in order to get it to reconnect. I would say 7 out of 10 times on Verizon. Has happened on iPhone 6+, 6s+,7+, 8+, x, and now xs max.
 

atlchamp

macrumors 68020
Original poster
Jun 19, 2012
2,056
1,245
Atlanta
Not quite, but I have had the same issue for several years. At home I am connected to wifi and have a weak signal so drops to either 3g or more often 1x. When I leave my house it will never reconnect to LTE I have to turn on airplane mode then turn it off in order to get it to reconnect. I would say 7 out of 10 times on Verizon. Has happened on iPhone 6+, 6s+,7+, 8+, x, and now xs max.
wow and you've never complained to apple about this?
 

irideti

macrumors member
Dec 20, 2012
34
3
My iPhone X would lose cellular network connection or refuse to connect after iOS 12 update in the following scenarios:

#1. Leaving wifi zone.
#2. Leaving no signal zone.
#3. Turning off Airplane Mode.

Strangely #1 does not happen when I'm leaving my home's wifi network, just public wifi. #2 was big problems when I was visiting NYC last week as I was constantly traveling in and out of no signal zone in subway. The cellular network comes back after reboot but it was very annoying because I often needed Google Map out of station. The problem is still there after I soft-reset the phone as well as the cellular network setup. Instead of restoring my phone to factory setup as next step, I'm waiting for the next iOS update which I hope will fix the problem. I read some people are having same problem in the AT&T forums so I'm sure it's not just my phone. I'm with T-Mobile and already have latest carrier update installed.
 

wza360

macrumors newbie
Oct 29, 2009
3
0
My friend is having same issue after updating to iOS 12. He is using iPhone 8. Can’t figure out the issue. 12.1.4 was released just couple of days ago and he didn’t update yet, but I doubt it will help. Angry one have any ideas?
 

DblHelix

macrumors 6502a
Mar 19, 2009
768
631
It is hit and miss for me but pretty much if it drops to 3g or lower it is about a 50/50 shot on verizon it will reconnect to LTE. This is real annoying when driving in rural areas and expecting it to reconnect and pick back up on nav. Makes for a dangerous drive when I don't know where I am going.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.