Issue with Messages on iCloud

Discussion in 'macOS High Sierra (10.13)' started by chrismarle, Jun 1, 2018.

  1. chrismarle, Jun 1, 2018
    Last edited: Jun 1, 2018

    chrismarle macrumors 6502

    Joined:
    Jun 18, 2011
    Location:
    Canada
    #1
    Hi guys,

    So, I wanted to do a fresh start with my 2016 MBP, so I just made a factory reset and updated it to 10.13.5. Since all my Messages are now on iCloud, thanks to 11.4, I activated the "Messages on iCloud" option in the Messages app on my Mac and expected all my conversations to be downloaded on my Mac. However, it's been a while and it's still "Downloading messages from iCloud" but nothing has shown up (except texts and iMessages that I've sent or received since I wiped my Mac).

    Is it normal?
     
  2. skillwill macrumors 6502

    Joined:
    Feb 12, 2008
    #2
    My experience was different. It downloaded all my messages PLUS a whole load that I know for a fact I've previously deleted - even from before iCloud Messages, so where they were being stored despite being deleted, I do not know!
     
  3. splifingate macrumors 6502

    splifingate

    Joined:
    Nov 27, 2013
    Location:
    ATL
    #3
    Enabled Messages in iCloud for iOS, yesterday, and let it sync . . . iMessages go back to 5/14

    Enabled Messages in iCloud for MacOS on MBP, this morning, and am letting it dl/sync . . . iMessages go back to 6/16

    Just enabled Messages in iCloud for MacOS on the 5,1, and it's currently downloading/synching . . . iMessages go back to 8/16

    ...let's see what tomorrow shall bring ;)
     
  4. SoYoung macrumors 6502a

    Joined:
    Jul 3, 2015
    #4
    For me, messages in icloud works with all my device but if I delete a message from my mac, it didnt delete on my other iOS device, but if I delete on my ios device, it will delete fine on macOS...
     
  5. roncron, Jun 4, 2018
    Last edited: Jun 4, 2018

    roncron macrumors 6502

    roncron

    Joined:
    Aug 15, 2011
    #5
    EDIT: Problem solved. In my iCloud settings, "Keychain" was unchecked on the Macbook that wasn't showing the checkbox option to enable messages in iCloud. I checked it, and now in Messages > Preferences > Accounts, I now have the checkbox option to enable messages in iCloud.

    I'd delete this post but I'm not sure how. But maybe someone else with the same problem will find this message and can try what seemed to solve the problem for me.

    ------

    I have another issue with Messages on iCloud.

    On one of my two macs, I don't have the checkbox option "Enable Messages in iCloud."

    I do on the other Mac (both are 13" macbook pros, both were updated to macOS 10.3.5 via App Store updates). And Messages on iCloud is working fine on my iPhone X and iPad Pro 10.5 (both running iOS 11.4 official release).

    I have two-factor authentication enabled.

    I'd be grateful if anyone has any suggestions.
     
  6. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #6
    For me, it looks like working once enabled. Lot's of message synced to the Mac. However, today, it seems the Message stop receive new message (the Mac side, iPhone is normal).

    So that I disable Message on iCloud (all device), and now everything back to normal.

    Once again, Apple disappointed me. Release a new function that not really ready.
     
  7. DeadheadTed macrumors newbie

    DeadheadTed

    Joined:
    Jun 4, 2018
    #7
    Will you be able to see messages in a browser by logging in to iCloud.com?
     
  8. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #8
    I can't

    I tried to login to icloud, hope that can clean up some message at there (to make sure clean it from the server side), but I didn't find a way to do it.
     
  9. DeadheadTed macrumors newbie

    DeadheadTed

    Joined:
    Jun 4, 2018
    #9
    Dang. That would be cool. Wish Apple would think these things through.
     

Share This Page