Issue with photos app in high sierra 10.13.4

Discussion in 'Mac Pro' started by troc, Apr 1, 2018.

  1. troc, Apr 1, 2018
    Last edited: Apr 1, 2018

    troc macrumors member

    Joined:
    Jun 26, 2006
    Location:
    The Netherlands
    #1
    Hi guys, after a lack of answers in the High Sierra forum, I thought I’d ask here :)

    I have a flashed 4,1 with a 3.46GHz 6-core cpu, flashed 7950 and a Samsung ssd mounted on a sonnet tempo carrier.

    Up to now, it’s been awesome but now I have an issue which I can’t fix and is bad en Ugh that m looking at getting an iMac!

    Essentially, in the photos app, most images display as red boxes. Sometimes only as thumbnails and sometimes as thumbnail and image. If I take a photo and add it to photos, it’s ok until I open it and zoom in. At which point it goes red and stays that way. The extra irritating thing is that this propagates to my iCloud images and destroys all the thumbnails and has also wrecked a few master images too!

    The library seems to mostly download onto my old laptop without problems and I have backups of course but this makes my Mac Pro useless as photography is kinda its main use...........

    I’ve tried reinstalling from the combo updater. I’ve tried a different drive mounted the conventional way. I’ve tried a complete fresh install on a fresh drive. I’ve tried the old gtx 120 (and that seems to make white rectangles instead of red) and I’ve tried a different screen. I’m out of ideas. I can only assume that the rest of you with similar upgraded cMPs done have this issue.

    So what could it be? RAM? CPU? I’m already on my second power supply.

    I also checked and it’s the same with all other accounts on the machine.

    Save me before I buy an emergency iMac (which will mean no modular Mac Pro or 2018 iMac or whatever as whatever I buy will have to last a good few years). I can’t afford or justify the iMac pro.
     
  2. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    No issue on my Mac (spec as per my signature, 10.13.4). There are 2 accounts, and multiple photo libraries on my Mac. Zero issue.

    Anyway, did you try to repair the library? Holding Command + Option, and then click Photos apps icon to start it.
    Screen Shot 2018-04-02 at 07.43.29.jpg
     
  3. troc thread starter macrumors member

    Joined:
    Jun 26, 2006
    Location:
    The Netherlands
    #3
    Yes, I tried repairing it without any improvement.

    For now, I’ve switched to using my MacBook Pro and iPad Pro for photo work whilst I decode what to do.

    I’m trying work out if this could be cpu or memory-related.
     
  4. filmak macrumors 65816

    Joined:
    Jun 21, 2012
    Location:
    between earth and heaven
    #4
    Can you revert to an older macOS version?
    Do you have a backup?
     
  5. troc thread starter macrumors member

    Joined:
    Jun 26, 2006
    Location:
    The Netherlands
    #5
    I can probably roll back to 10.13.3 easily enough as I have a backup of that. Might be able to reinstall Sierra I guess but there’s issues with the new filing system which might complicate things there. It’s odd thoug that these issues happened with 10.13.4 which makes me wonder if there’s an issue with my hardware and something that’s changed in the .4 release.
     
  6. JedNZ macrumors 6502

    JedNZ

    Joined:
    Dec 6, 2015
    Location:
    Deep South
    #6
    I have had red boxes on Photos with my system as well. My setup included having a GT120 installed but no connected, and I read somewhere that having an unconnected GPU installed might cause rendering issues such as the red box one we have in Photos. I took out the GT120 today so I can install my USB 3.0 PCIe card, and the rotate solution fixes all of the photos with red boxes around them. I can see that Photos connects to iCloud when I do this, so it must be something to do with the thumbnails, and the extra GPU causing some issues with that.
     

Share This Page