iPhone Issue with restoring after JB

Discussion in 'Jailbreaks and iOS Hacks' started by IndoX, Feb 20, 2013.

  1. IndoX macrumors regular

    Joined:
    Oct 12, 2011
    #1
    So, I have an iPhone that's JB. However, I decided I wanted to restore it back to normal and with it update to iOS 6.1.2 but for some reason I can't.

    Whenever I tried to reset all content and settings my iPhone stays in the 'thinking' phase indefinitely (I cancelled it after 2 hours of waiting). I can't update to iOS 6.1.2 OTA because I get an error. If I try to do DFU mode whenever I try to download iOS 6.1.2 with my mac (either wirelessly or wired) I get a timeout error half way through the download.

    I wanted to test this out, so I tried restoring my iPad after the failed attempt with my iPhone and iOS 6.1.2 downloaded perfectly and it updated/restored my iPad...

    So I don't know what to do to restore my iPhone because everything i try doesn't work.... any thoughts? :\
     
  2. dextr3k macrumors 6502

    Joined:
    Nov 26, 2012
    #2
    If you are failing, then maybe your connection isnt strong enough. Maybe if you download the 6.1.2 ipsw, then do an shift/option restore and point to the self downloaded file it might work?
     
  3. BigEm macrumors newbie

    Joined:
    Dec 11, 2012
    #3
    You should NOT reset all settings when you're jailbroken and you should NOT update OTA as well.

    Download an IPSW file (6.1.2 for your phone model) from a source then shift+click restore on iTunes. Point iTunes to your downloaded IPSW and wait until it finishes restoring.
     
  4. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #4
    ^^^^^

    Correct

    You cannot use the reset all on JBen devices as the root file structure has changed. For the same reason the OTA does not work.

    Either restore in itunes as above or in DFU-mode which is best.
     

Share This Page