Issue with secure websites

Discussion in 'iPhone' started by Pgoz, Feb 25, 2014.

  1. Pgoz macrumors newbie

    Aug 30, 2013
    I am having problems visiting sites that are secured (https). I'm not sure when, but lots of websites have changed to https, including google's search engine.

    When I am browsing on my phone, I can access, but not I also cannot access startpage or any other search engine that uses google's results. As a third example, I can visit but when I try to sign in to my account, I cannot because it is

    I have looked for a solution, but only found answers for DNS issues on desktops. It may be a similar issue, but I haven't come across anything that makes sense to me. Part of the problem finding a solution is apples help forum is also https. On top of that, searching for https in help forums returns every single forum post because they all start with https.

    Here's one final thing that adds some confusion: as soon as I log on to any wifi source, I can visit all the https pages I want. So it is only blocking secure web pages on mobile data.

    I have no clue about this. Any help is greatly appreciated. (Although, I am absolutely NOT INTERESTED in upgrading to iOS 7)

    Thanks in advance

    Iphone 3GS, iOS 6.1.3, browsers tried: safari and dolphin. Carrier: GoSmart by T-Mobile.
  2. Pgoz thread starter macrumors newbie

    Aug 30, 2013
    Thanks. I'm not sure if that applies to me since I am not using iOS 7 or OSX 10.9. It doesn't appear iOS7 is even available for the 3GS.

    I will visit the gotofail site and see what happens.

    Update: I can not load or ANY https web page.
  3. Bacong macrumors 68020


    Mar 7, 2009
    Westland, Michigan
    it's not simply an iOS 7 bug, it exists in iOS 6 too.

    Have you tried turning on Airplane mode (to reboot mobile data) and rebooting the phone?
  4. Pgoz thread starter macrumors newbie

    Aug 30, 2013
    No that didn't help.

    About the ssl flaw- it seems such a flaw would make navigating secure sites more dangerous, but not stop me from doing it. Am I incorrect?
  5. C DM macrumors Westmere

    Oct 17, 2011
    If it's happening to you only on cellular data, have you checked if it might be something related to your carrier? Do you know of any other phones (hopefully iPhones) with the same carrier that work just fine and don't have this issue?
  6. bruinsrme macrumors 603


    Oct 26, 2008
  7. Pgoz thread starter macrumors newbie

    Aug 30, 2013
    My time and date are set to automatic updates.

    I don't know anybody or have access to another phone on my carrier. It is gosmart by t-mobile, and uses t-mobiles apn settings for data.

    I will be calling them today.

Share This Page