Issue with Steam and Lion Start-Up

Discussion in 'Mac OS X Lion (10.7)' started by MacBookPro13", Jul 4, 2011.

  1. MacBookPro13" macrumors 6502a

    MacBookPro13"

    Joined:
    Jan 25, 2011
    Location:
    Ireland
    #1
    Since installing Steam, I get this screen every time I turn on my MacBook Pro.

    [​IMG]
     
  2. zulumonk macrumors member

    Joined:
    Nov 25, 2009
  3. PatM macrumors newbie

    Joined:
    Jul 20, 2010
    #3
    Roaring apps says that it is compatible with Lion. Must be something on your individual systems that is causing fits. Maybe at the Roaring Apps sight you can get more info.

    http://roaringapps.com/app:97

    Pat
     
  4. th3r3ds0x macrumors regular

    th3r3ds0x

    Joined:
    Jul 26, 2011
    Location:
    Louisiana
    #4
    I too noticed this issue. Clean install of Lion with a fresh download of steam as well. Go to the Steam preferences and disable steam startup when your computer starts and the issue is gone. I'll just launch steam manually until the issue is resolved with an update.
     
  5. JacaByte macrumors 6502

    Joined:
    Dec 26, 2009
    #5
    If you want steam to start when you start your Mac, why not just put an alias to Steam in your user's startup folder?

    Edit: My bad, OS X doesn't have one of those anymore. You'll have to go to System Preferences > Users (Or whatever they renamed Accounts to under Lion) > Login Items, press the plus button, then select Steam from your applications folder.
     
  6. th3r3ds0x macrumors regular

    th3r3ds0x

    Joined:
    Jul 26, 2011
    Location:
    Louisiana
    #6
    Getting it to load with the OS isn't much of an issue, just seems that on some machines at least there is an issue with it not loading properly at startup under Lion instead just opening a finder window showing the contents of "MacOS" which is located in the steam.app package. I'm guessing a simple update from Valve to fix this little Lion issue.
     
  7. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #7
    For what its worth, my system was upgraded from Snow Leopard with Steam installed. It's been working fine for me although I can't remember the last time I rebooted.

    nm... lol..
     
  8. CurtisLayCraft macrumors newbie

    Joined:
    Aug 11, 2011
    #8
    Solution

    You can go into your System preferences and click "Users and Groups".
    Click your user Account and switch to the "Login Items" tab. Remove the steam folder from the list.

    Now open Steam.app. While the program is launching, right click on it's dock icon. Go to "Options" and select "Open at Login". This adds the Steam app to the login apps instead of the app folder that is put there by accident.
     

Share This Page