Issue with T-Mobile (UK) Mobile Broadband Dongle (Huawei E220)

Discussion in 'Mac Basics and Help' started by EdRooney, May 6, 2011.

  1. EdRooney macrumors newbie

    Joined:
    May 4, 2011
    #1
    Firstly, I am new to the forums and my first post and subsequent updates manageed to P!$$ off a lot of people so I hope I get this one right!

    I am a convert from Windows to PC and as such still learning!

    I have a mobile broadband dongle from T-Mobile (UK) which I have had for a number of years now and it has worked, consistently, extremely well on my windows based laptop. This was not the case when I plugged it in to my 13" MacBook Pro that I have just purchased as part of my conversion.

    I concluded I must be doing something wrong.

    The modem is a Huawei E220 and I have done all the firmware upgrades etc that all the other forums seem to suggest.

    The last suggestion from T-Mobile was that I utilise a more up to date broadband dongle to install the latest connection manager software on to my MBP. I have done this.

    I now have no error messages when I plug the dongle in to the MBP and I know the driver is OK etc because I do manage to connect and surf the web etc.

    My issue is that after a short period of time (this can vary between 1min and 5mins) the Dongle appears to hang or freeze.

    The light on the dongle remains blue but no data is transferring.

    I have installed little snitch also which shows me the red outgoing data but no green incomming on the little display in the menu bar.

    I have made assumptions that the driver, connection manager, firmware, little snitch or firewall etc are all ok because I am gettign a connection at some point for a short period of time.

    I was wondering if anyone has had similar issues or can indeed assist me in the resolution?

    I am wondering if it is a setting on the MBP because of the device failing after a period of time?

    The OS id Snow Leopard and I believe I am up to date with my software releases.

    Any help gratefully received !
     
  2. EdRooney thread starter macrumors newbie

    Joined:
    May 4, 2011
    #2
    Actually just read another post about 64-bit and 32-bit kernel and wondering if that is the root cause of my issue?

    I will try the 32-bit when I get home later.

    Incidentally, will I notice much difference between 64-bit and 32-bit?

    Will update later :eek:)
     
  3. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #3
    Lol, welcome back. The only benefit to 64-bit is the ability to utilize ridiculous amounts of RAM. There are a couple minor processor benefits as well, but nothing worth noting for the the majority of purposes. HERE is a good guide to the differences.
     
  4. EdRooney thread starter macrumors newbie

    Joined:
    May 4, 2011
    #4
    Thanks for the feedback.

    I have solved the issue. I have changed for a wireless pointer as that modem type is out of date for Snow Leopard it would seem.

    I did try everything that T Mobile technical have worked with me on to try and resolve but we all concluded a more up to date modem was the solution.
     

Share This Page