Issue with Wireless in Bootcamp

Discussion in 'Mac Pro' started by Ryan P, Oct 8, 2010.

  1. Ryan P macrumors regular

    Joined:
    Aug 6, 2010
    #1
    I've got an odd issue with my finally arrived Mac Pro where the Wireless works flawlessly in OS X but almost not at all in Windows 7 Ultimate x64.

    My first real experience with bootcamp, but I put on all the windows updates and did the bootcamp setup. I'm using an older 1TB Time Capsule for Wifi and it connects with pretty good strength over the standard and the 5ghz channel and shows around 200 Mb/sec speed. It seems to be able to resolve hosts but can't ping them. IE and Firefox go nowhere. Again once I boot into OS X it is all peaches and cream.

    It was working just fine with our Cisco wireless router at work, even in Windows.

    Bizarre!
     
  2. Ryan P thread starter macrumors regular

    Joined:
    Aug 6, 2010
    #2
    just an update that disabling wireless security is one fix...hope there is a better one..will monkey with the time capsule settings.....
     
  3. Ryan P thread starter macrumors regular

    Joined:
    Aug 6, 2010
  4. Ryan P thread starter macrumors regular

    Joined:
    Aug 6, 2010
    #4
    bizarre is right, I actually think now that it is not a the encryption setting in the time capsule but my airport express I use for music that is causing the issue. changing the encryption knocks it off the network and was temporarily fixing the issue. As soon as I brought it back onto the network the Win 7 box kept falling off the network!

    Ryan
     
  5. gugucom macrumors 68020

    gugucom

    Joined:
    May 21, 2009
    Location:
    Munich, Germany
    #5
    Can you post a screen shot of your Windows hardware manager. It would give a clue how your drivers have installed.

    I assume you have installed all the drivers with the Snow Leopard disk under Windows? It could be possible that some drivers are missing due to an incomplete install in 64-bit mode.

    Basically all the drivers are on that disk and you can install them except some stuff that is needed for Time Capsule. This works the same way as with the Snow Leo disk. You insert the Time Capsule disk under Windows and install the driver. After that you have to update it several times with Apple update under Windows.

    Hope that helps.
     
  6. Ryan P thread starter macrumors regular

    Joined:
    Aug 6, 2010
    #6
    Ya ignore my post right above, that was another misdirection.....I do have it working now. What I think is really the issue is Windows 7 doesn't seem happy with the Time Capsule in "Bridge Mode". It is connected to a DSL router and the Time Capsule suggests the best mode for that is "Bridge Mode" but Windows 7 can't seem to understand how to properly route traffic even though OS X handles if fine.

    What I did was switch it to double NAT (network address translation) mode and now it has been working well for several hours. I was able to re enable WPA2.

    What was throwing me off was every time I made any mode change, the Time Capsule would reboot and Windows 7 would work for a couple minutes and then stop, so it made it seem like every setting I tried fixed it. But them it would stop and leave me befuddled again.
     

Share This Page