Issues caused by DHCP changing machine name

Discussion in 'macOS' started by CashGap, Oct 4, 2007.

  1. CashGap macrumors 6502

    CashGap

    Joined:
    Sep 15, 2007
    Location:
    Music City, USA
    #1
    2.16 MBP, 3gb, 10.4.11

    I've been trying to figure out why my MBP has several "issues" at work but none at home. At work, I connect to a gig switch port on the corporate network. I have the option of connecting to an 802.11g "outside" network if I don't need corporate resources. At home I connect to an 802.11n network with Comcast.

    I often sleep the machine when I'm going from one place to the other.

    I see several of these messages on the console whenever I have a SBOD or other problem:

    Oct 4 15:34:10 SRS-MBPro mDNSResponder: Repeated transitions for interface en3 (10.211.55.2); delaying packets by 5 seconds

    Once I have SBOD, I may or may not be able to force quit the offending application. I may or may not be able to gracefully shutdown.

    I stumbled onto Mac Pilot and found that the 'Clear "lookupd" Cache' option will usually return things to normal. That caused me to explore the machine name (host name).

    I think the corporate DHCP server is causing my host name to change when I get an address.

    Terminal prompt right after booting, SRS-MBPro is the machine name I assigned:

    SRS-MBPro:~ username$

    Terminal prompt when I attach to the 802.11g network:

    srs-mbpro:~ username$ (note case change)

    Terminal prompt after I attach to the corporate gig ethernet network:

    nt-12932:~ username$

    nt-xxx is the range of machine names assigned to the Windows machines.

    I think I'm looking for a way to have my MBP accept the ip address, gateway, dns from the corporate DHCP server but reject the machine name.



    If necessary, I'd like to handle this 100% on my MBP rather than asking IT to "accomodate" my Mac. Of course... they work for me, so if the DHCP server configuration needs to change, it will be changed.

    THANKS
     
  2. CashGap thread starter macrumors 6502

    CashGap

    Joined:
    Sep 15, 2007
    Location:
    Music City, USA
    #2
    Perhaps solved...

    /etc/hostconfig had no entry for HOSTNAME

    Added "HOSTNAME=SRS-MBPro" and it seems to have worked.

    "HOSTNAME=-AUTOMATIC-" would be the same as no entry.
     

Share This Page