Issues connecting my iPhone 5 to a 2.4 GHZ A/B/G wifi router

Discussion in 'iPhone' started by iMegan415, Sep 29, 2012.

  1. iMegan415 macrumors newbie

    Sep 29, 2012
    Hey all,
    I'm wondering if someone else is having a similar issue. I got my Verizon iPhone 5 last Tuesday, and have not had any problems with wifi until now. At college, I can connect to multiple networks and have always had decent signal. This weekend, I'm home for the weekend, where my parents are using an old Netgear WGT 624 router, 2.4 GHZ, with WPA2 security, that does not support wireless N. All the computers in the house--my Mac, Mom and Dad's Del laptops, and Mom's iPod touch 4th generation and my iPad 2 connect fine. My iPhone 5, however, displays the "unable to join network" message. Is this a limitation in the hardware of the iPhone 5? Is my router just too old, or am I missing something really dumb? I've reset the router, upgraded firmware, and tried to forget/rejoin the network. Pings from other sources are fine, and I'm getting Internet. Also, I'm pretty sure this isn't a hardware problem with my 5, as I can connect at campus and at friends' houses. What do you guys think? I'd appreciate any help/advice you might be able to give me.
  2. kappaknight macrumors 68000


    Mar 5, 2009
    Opposite problem here. My iPhone 5 will join my wireless G on the 2.4Ghz band fine, but it won't join the wireless N on the 5.0Ghz band even though it can see it and the password is right.
  3. njAndrew macrumors newbie

    Oct 3, 2012
    I have the same problems. My iphone5 can connect to wifi at work and various hotspots (apple store, starbucks, ...). I can't connect at home to my netgear WGT 6.24 but various apple products such as iphone4s, touch, ipad have no issuse. Apple store was no help, it worked fine there and they 'haven't hear of this issue' although is is all over the internet.

    IF you figured anything out let me know.
  4. jonfarr macrumors 6502a


    Jun 29, 2012
    my i5 will always connect to the 2.4 band even when the 5Ghz is available. When I do force it to connect to the 5, I get very a scattered connection and it eventually drops it altogether.
  5. MrXiro macrumors 68040


    Nov 2, 2007
    Los Angeles
    I use an Airport Extreme and I seem to get a good connection at all times. I just have a deadspot in my apartment that works for my iPad (3rd gen) but not for my iPhone 5 which is kind of weird.
  6. iMegan415 thread starter macrumors newbie

    Sep 29, 2012
    Hey guys,
    Sorry it has taken me so long to reply. I ended up needing a quick fix, as I was also having the Verizon data issue and had used an excessive amount of data, but didn't know it was an issue and thought it was my net activity. Anyway, I ended up going to a local computer store and picking up a very cheap N wireless router. It's kind of a piece of crap, but at least now all my devices are connecting again, and my parents are reporting faster throughput speeds. Next time I go back home, I'll probably fire up the old router and try to solve this, just for kicks. If I find anything, I'll post back.
  7. noodlehead macrumors member

    Sep 10, 2008
    "unable to join"? try changing wireless PW

    I got an Arris TG 862G gateway from Comcast (BUT THIS FIX MAY WORK WITH OTHER ROUTERS/GATEWAYS).

    Had trouble accessing the router at first but finally got into it by putting http// into browser address field. Default name is: "admin", PW is "password". (Access info is on the net for all routers/gateways)

    Anyway, I had been using the default wireless password, which was long and is case sensitive. Was okay with that until I tried my iPhone 5. Got "Unable to join network" or something like that. iPhone 4s, iPad, and Mac Pro worked fine. Note: This is different than having the wrong password, in which case it says "Wrong password" or something like that. I had seen this problem on one other gateway (from Sonic) with my iPhone 5, but I just ignored it because it wasn't anywhere I needed to be often.

    The upshot is I decided to change both the network name and wireless password in the gateway settings for convenience reasons (I used the "Wizard), BUT THIS FIXED THE iPhone 5 connection PROBLEM! Just changing the password is what did it, I believe (My next step was to change the security type, but that turned out to be uneccesary). I had seen this mentioned somewhere before but it made no sense. What does the iPhone care what the password is? So try this first if you are having a problem. I used a simple password. Could it be the iPhone 5 needs shorter passwords?

    Note: Network name and wireless password are different than gateway/router access name & password. The access passwords are to get in and change things. The network name is what shows up on your device, and the network PW is how you access the network (with your computer or iPhone). I'm sure this is obvious to most of you but many folks seem confused by it. You can change both once you are in the router settings. What I am talking about is the wireless password.
  8. samudra macrumors newbie

    Nov 20, 2014
    this is how i solved it

    Hi guys

    I went to the Wifi connection, pressed the little i icon next to it and then in DHCP section i removed the DNS settings and changed it to google and it all started working for me again.

    May be it will just work for you. Give it a try !


Share This Page