Issues ejecting disk on iMac

Discussion in 'iMac' started by AndrewVenner, Mar 10, 2008.

  1. AndrewVenner macrumors member

    Joined:
    Jan 13, 2008
    #1
    Alright, so the other day I was burning a disk in itunes. I decided however that I wanted to cancel the burn, and it did so. Then ever since, I have not been able to eject the disk with any program, and this morning when I went to iDvd, it said I don't have a supported superdrive. Can anyone help me with this please????
     
  2. rhodalinsky macrumors member

    Joined:
    Jan 22, 2008
    #2
    To get your disk out did you try restarting your mac and hold down your mouse?
     
  3. DTG macrumors member

    Joined:
    Oct 5, 2003
    Location:
    UK
    #3
    I've had this happen to me before with an iMac G5, I found persistence was the key!

    Have a look here. There are plenty of suggestions to how to go about solving this.

    Let us know how you get on.
     
  4. AndrewVenner thread starter macrumors member

    Joined:
    Jan 13, 2008
    #4
    I got the disk out. I tried the holding down the mouse thing before, but for whatever reason, it didn't work. Just tried it again, and it popped right out.

    Cheers!
     

Share This Page