Issues playing rented movies

Discussion in 'Apple TV and Home Theater' started by sab46, Feb 11, 2009.

  1. sab46 macrumors newbie

    Joined:
    Oct 21, 2008
    #1
    Has anyone else had issues playing rented movies on their Apple TV?
    I've rented ~3 movies and each one has had the same issue. Once its downloaded enough to start playing, I get the popup that says I can start it. Once I start the movie, all I get is a gray screen and no sound. I can exit out and try again with the same result. Fast forwarding/rewinding doesn't do anything.
    The only fix I've found it to reboot the atv by unplugging it. Once it boots up, the download resumes and I can play the movie w/o any more issues.
    I've only tried HD rentals so I don't know if I would have the same problem with SD movies.

    Besides this, I have no issue with my atv. Anyone else seen this or know how to fix it?

    Thanks!
     
  2. pjarvi macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #2
    This happens to me about once every 2-3 weeks. Restarting the AppleTV is the only fix I know of. You can restart the AppleTV by pressing Menu+Down on the remote for 5+ seconds until you see the light turn amber, it will prompt for desired language and then present a screen where you can select to restart the device. This is the single biggest bug that annoys me with the current version of software.
     

Share This Page