iPhone Issues purchasing items in Apple App Store and Music Store after JB

Discussion in 'Jailbreaks and iOS Hacks' started by Shan S., Jan 26, 2014.

  1. Shan S. macrumors member

    Joined:
    Apr 28, 2012
    #1
    Anybody having trouble purchasing items on the Apple App Store after the evasi0n jailbreak?

    I did the JB on a 5s (7.04). Everything works great except Apple App Store and music store purchases.

    I get the xxx can not be purchased at this time message in the App Store.

    However at some time later I can download the app again. It will show up in the item purchased section of the store. I can then install from there.

    In the music store nothing happens. I just cannot purchase anything.

    I also noticed that when logging out of the store and back in that it took a few times for the phone to accept my user name and password.

    I have tried the following:

    1. Rebooted the phone with holding power button and center button

    2. Log out and then log back into the store. Both with and with out a phone reboot.

    3. Cleared all the settings on the phone and rebooting. Then logging back into the store.

    Nothing makes a difference. Anybody else have these problems?

    Looking for some mother items to try and help.

    Should I just do a full restore to 7.04 through iTunes and trying JB again?

    Shan
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    what tweaks do you have installed?
     
  3. Shan S. thread starter macrumors member

    Joined:
    Apr 28, 2012
    #3
    Just these:
    - swipe keyboard
    - asktocall
    - asktosend
    - noslowanimations
    - slide to kill
    - action menu plus pack (includes action menu)
    - Iconoclasm
    - infinidock
    - Shrink
    - icon renamer
    - MultiIconMover
     
  4. Jman13 macrumors 68000

    Joined:
    Aug 7, 2011
    Location:
    Columbus, OH
    #4
    Issues purchasing items in Apple App Store and Music Store after JB

    I had this issue when I first did the jailbreak. I had to restore and rejailbreak. I made sure to log in and buy a (free) app after restoring my backup but before jail breaking the second time. Works fine now.
     
  5. dmick89 macrumors member

    Joined:
    Dec 31, 2013
    #5
    Same thing I had to do. Restoring was only thing that worked. No problem after jailbreaking again.
     
  6. Shan S. thread starter macrumors member

    Joined:
    Apr 28, 2012
    #6
    Thanks for the info. I will try the same steps then. Again thanks!
     
  7. Shan S. thread starter macrumors member

    Joined:
    Apr 28, 2012
    #7
    Steps worked perfectly. Thanks again for the info!
     

Share This Page