iPhone Issues resetting a jailbroken 3G

Discussion in 'Jailbreaks and iOS Hacks' started by mweb, Nov 4, 2012.

  1. mweb macrumors newbie

    Joined:
    Nov 4, 2012
    #1
    Hi, sorry if it's been asked or covered but after quite a lot of searching, trial and error I'm a but stuck. I'm not very familiar with jailbreaking and I'm learning as I'm going.. I'm trying to totally reset/unjailbreak an iphone 3G.

    Trying to just restore it in itunes gaves the 1015 error.

    When I got it, it was in showing the connect to itunes graphic on the screen so I didn't have any idea of previous settings etc but after some trial and error I've been able to restore it using redsn0w 0.9.6rc16, "iPhone1,2_4.2.1_8C148_Restore" and "iPhone3G_4.2.1_8C148_Custom.[iPhoneRock.Com]". That basically leaves it from what I can tell working better but still jailbroken and with Cydia installed.

    It's picked up by itunes and I then set it up as a new phone. If I then try to do a standard restore though in itunes it just goes back to error 1015, repeating the redsnow process gets it working again but with Cydia as above.

    In that state I can see:
    Model MB489B, Modem Firmware 06.15.00

    I tried to use the redsn0w process and then at the restore stage use what appears to be a standard firmware instead of the 'custom' one but that didn't work either.

    Thanks for any help you can offer.
     
  2. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #2
    Modem Firmware 06.15.00 means iPad baseband is installed in order to unlock. You cannot restore normally with iTunes because of this baseband.

    You've got two options:

    Use redsn0w to make a no baseband ispw and use that to restore in iTunes.

    Or

    You can downgrade the baseband (iClarified.com for guide) and restore.
     
  3. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #3
    Once you get 1015 error. Shut down iTunes. Run tiny umbrella, click on your device and hit exit recovery. It should bring your phone to emergent call screen.
     
  4. mweb thread starter macrumors newbie

    Joined:
    Nov 4, 2012
    #4


    Thank you both for the help, I've only just been able to pick your replies up and haven't tried them yet, I'll look up iClarified.com but just on the option of using redsn0w to make a no baseband ispw - is that something redsn0w can do (create a no baseband ispw) as I couldn't see an option to create one, or do I need to somehow edit an ispw - I've only really seen that you can download ispw's then deploy them using reds0w. Which makes me think I need to find an ispw that has no baseband. I thought I had but there was an error when trying to deploy it.

    Thanks again, mean time I'll try iClarified.com.
     
  5. mweb thread starter macrumors newbie

    Joined:
    Nov 4, 2012
    #5
    Hi. I've downloaded the latest redsn0w, 0.9.15.b3, and followed the instructions here; http://www.iclarified.com/entry/index.php?enid=22652 ("How to Downgrade Your iPhone 3GS, 3G Baseband for Unlock")

    I don't recall it showing anything to do with "limera1n" (step 11) and as for step 14, after redsn0w says done the rest is on the device, the iphone screen is black (on, but no logos or text). First time that happened I turned the phone off and on and it restarted but no change. Second time around I've just left it in that state and eventually after 5-10 minutes it just powered down. Starting it up again it loads up and again no change.

    These come from the redsn0w identify function:
    ProductType: iPhone1,2
    ProductVersion: 4.2.1
    ModelNumber: MB489
    FirmwareVersion: iBoot-931.71.16
    HardwareModel: N82AP
    BasebandVersion: 06.15.00
    BasebandBootloaderVersion: 6.4_M3S2
    BuildVersion: 8C148
     

Share This Page