Issues with embedded video in Safari

Discussion in 'macOS' started by nope7308, Dec 15, 2011.

  1. nope7308 macrumors 65816

    nope7308

    Joined:
    Oct 6, 2008
    Location:
    Ontario, Canada
    #1
    For whatever reason, I cannot watch embedded videos on some websites. For instance, I cannot watch any videos on globeandmail.com, or cbc.ca. When I attempt to play the video, it perpetually "loads". Curiously, I have no issues watching embedded videos on other websites (e.g., Antiques Roadshow [don't laugh]).

    I'm running SL with full updates, Safari 5.1.2, and I have repeatedly deleted/reinstalled the most recent version of Flash. I've also disabled/deleted all ad-blocking extensions, but I still can't watch any video on either of those websites. What gives?

    It's beyond frustrating... any ideas?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    I tried globeandmail.com with all extensions, adblockers, flash-blockers, pop-up blockers disabled and got the same results... no video. It could simply be an issue with the site, and not your browser.
     
  3. nope7308 thread starter macrumors 65816

    nope7308

    Joined:
    Oct 6, 2008
    Location:
    Ontario, Canada
    #3
    Hmm, what about cbc.ca/thenational?

    I used to be able to watch video on that website, but then it abruptly stopped working. When I view the video requirements on globeandmail.com, it says the following:

    On Macintosh (OS X):
    Safari 4.x -- the latest version
    Opera 10.x -- the latest version
    Firefox 3.x -- the latest version


    To my knowledge, I definitely meet the minimum requirements. So, what gives?
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Same story. You might try another browser.
     
  5. Edd.Turner macrumors newbie

    Joined:
    Dec 16, 2011
    #5
    Same here…

    On Safari 5.1.2, Snow Leopard, all patches and updates, no Flash Blockers (and only suddenly, since yesterday morning when I last synced my iPhone).

    Flash does work in Shiira, but who wants to change browsers?
     
  6. Edd.Turner macrumors newbie

    Joined:
    Dec 16, 2011
    #6
    At the risk of sounding useful…

    The issue is not present in a guest account, nor when booting in safe mode (hold shift at the chime). This suggests a conflict/what used to be an 'extensions' issue.

    Am now about to re-boot into normal mode and will report back.
     
  7. Edd.Turner macrumors newbie

    Joined:
    Dec 16, 2011
    #7
    And it worked!

    So, anyone suffering this issue could do worse than trying a safe boot.

    HTH.
     
  8. noxid101 macrumors newbie

    Joined:
    Mar 1, 2012
    #8
    This worked for me.

    Go to Safari Preferences>Security>Enable Extensions

    This made some embedded videos re-appear. So now I can see all videos on all websites.

    Let me know if this helps.

    Dylan

    ----------

    Go to Safari Preferences>Security>Enable Extensions

    This worked for me let me know if this helps you.

     

Share This Page