Issues with External Hard Drives in Mountain Lion!

PCWebbJR

macrumors member
Original poster
Jun 20, 2012
83
0
Chicago, Illinois
I just got my rMBP yesterday with ML installed. I've been using a firewire, 1TB G-Tech external hard drive with absolutely no issues to speak of until now. It it formatted with mac os extended journal.

When it is plugged in it takes forever for my computer to restart and often will freeze the system. It has gotten to the point now that I need to wipe the drive because there are so many corrupted files on it.

When it isn't plugged in my computer restarts lightning fast and has no issues whatsoever.

Clearly it's an issue with communicating to the external, but I know no more than that.

Anyone else having similar issues now that they've upgraded to ML?
 

charlieegan3

macrumors 68020
Feb 16, 2012
2,395
14
U.K
My issue isn't really the same but since my ML upgrade my time machine backups have been painfully slow over what is meant to be a fast USB3 connection...
 

PCWebbJR

macrumors member
Original poster
Jun 20, 2012
83
0
Chicago, Illinois
Now I had a kernel panic without the external connected. I'm confused by what's going on.

Interval Since Last Panic Report: 55938 sec
Panics Since Last Report: 1
Anonymous UUID: 203AA73B-E27D-4107-B2BE-A9BDC2CAE7D9

Sat Aug 11 12:51:40 2012
Machine-check capabilities 0x0000000000000c09:
family: 6 model: 58 stepping: 9 microcode: 18
Intel(R) Core(TM) i7-3720QM CPU @ 2.60GHz
9 error-reporting banks
threshold-based error status present
extended corrected memory error handling present
Processor 0: no machine-check status reported
Processor 1: no machine-check status reported
Processor 2: no valid machine-check state
Processor 3: no valid machine-check state
Processor 4: no valid machine-check state
Processor 5: no valid machine-check state
Processor 6: no valid machine-check state
Processor 7: no valid machine-check state
panic(cpu 7 caller 0xffffff802dcb8389): "Machine Check at 0xffffff7fafbbf92f, registers:\n" "CR0: 0x000000008001003b, CR2: 0x00000001096c6868, CR3: 0x00000000305ff000, CR4: 0x00000000001606e0\n" "RAX: 0x0000000000000031, RBX: 0xffffff804fe97800, RCX: 0x0000000000000001, RDX: 0x0000000000000000\n" "RSP: 0xffffff8201e53d70, RBP: 0xffffff8201e53da0, RSI: 0x0000000000000007, RDI: 0x0000000000000007\n" "R8: 0x0000000000000000, R9: 0x7ffffffffffffffe, R10: 0xffffff802e2bdc27, R11: 0x0000000000000201\n" "R12: 0x0000000000000007, R13: 0xffffff80500ad740, R14: 0x0000000000000000, R15: 0x00000000000008f8\n" "RFL: 0x0000000000000046, RIP: 0xffffff7fafbbf92f, CS: 0x0000000000000008, SS: 0x0000000000000010\n" "Error code: 0x0000000000000000\n"@/SourceCache/xnu/xnu-2050.7.9/osfmk/i386/trap_native.c:280
Backtrace (CPU 7), Frame : Return Address
0xffffff81f5addec0 : 0xffffff802dc1d5f6
0xffffff81f5addf30 : 0xffffff802dcb8389
0xffffff81f5ade0a0 : 0xffffff802dcced7f
0xffffff8201e53da0 : 0xffffff7fafbb012e
0xffffff8201e53e80 : 0xffffff7fafbaf515
0xffffff8201e53f30 : 0xffffff802dcb8bdb
0xffffff8201e53f50 : 0xffffff802dc2f193
0xffffff8201e53f90 : 0xffffff802dc2f448
0xffffff8201e53fb0 : 0xffffff802dcb2677
Kernel Extensions in backtrace:
com.apple.driver.AppleIntelCPUPowerManagement(196.0)[BBF44990-49F7-3780-AF55-C26B48EDE4C4]@0xffffff7fafbad000->0xffffff7fafbd5fff

BSD process name corresponding to current thread: kernel_task

Mac OS version:
12A269

Kernel version:
Darwin Kernel Version 12.0.0: Sun Jun 24 23:00:16 PDT 2012; root:xnu-2050.7.9~1/RELEASE_X86_64
Kernel UUID: 8D5F8EF3-9D12-384B-8070-EF2A49C45D24
Kernel slide: 0x000000002da00000
Kernel text base: 0xffffff802dc00000
System model name: MacBookPro10,1 (Mac-C3EC7CD22292981F)

System uptime in nanoseconds: 3143272801232
last loaded kext at 3118137284845: com.apple.driver.AppleThunderboltPCIUpAdapter 1.2.5 (addr 0xffffff7faffbc000, size 32768)
last unloaded kext at 1999396572493: com.apple.driver.AppleUSBCDC 4.1.21 (addr 0xffffff7faffb9000, size 12288)
loaded kexts:
com.apple.filesystems.smbfs 1.8
com.apple.driver.AppleFWOHCI 4.9.5
com.apple.driver.AppleBluetoothMultitouch 75.15
com.apple.driver.AudioAUUC 1.60
com.apple.driver.AppleHWSensor 1.9.5d0
com.apple.iokit.IOBluetoothSerialManager 4.0.9f8
com.apple.filesystems.autofs 3.0
com.apple.driver.AGPM 100.12.69
com.apple.driver.ApplePlatformEnabler 2.0.5d4
com.apple.driver.X86PlatformShim 1.0.0
com.apple.driver.AppleMikeyHIDDriver 122
com.apple.driver.AppleHDA 2.3.0f2
com.apple.driver.AppleUpstreamUserClient 3.5.10
com.apple.driver.AppleMikeyDriver 2.3.0f2
com.apple.driver.AppleMuxControl 3.2.6
com.apple.driver.AppleLPC 1.6.0
com.apple.iokit.BroadcomBluetoothHCIControllerUSBTransport 4.0.9f8
com.apple.driver.AppleMCCSControl 1.0.33
com.apple.driver.AppleIntelHD4000Graphics 8.0.0
com.apple.driver.AppleIntelFramebufferCapri 8.0.0
com.apple.driver.AppleSMCPDRC 1.0.0
com.apple.driver.AppleSMCLMU 2.0.2d0
com.apple.GeForce 8.0.0
com.apple.iokit.IOUserEthernet 1.0.0d1
com.apple.Dont_Steal_Mac_OS_X 7.0.0
com.apple.driver.ApplePolicyControl 3.2.6
com.apple.driver.AppleUSBTCButtons 235.4
com.apple.driver.AppleUSBTCKeyboard 235.4
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
com.apple.BootCache 34
com.apple.driver.XsanFilter 404
com.apple.iokit.IOAHCIBlockStorage 2.2.0
com.apple.driver.AppleUSBHub 5.1.6
com.apple.driver.AppleSDXC 1.2.2
com.apple.driver.AirPort.Brcm4331 600.15.20
com.apple.driver.AppleAHCIPort 2.4.0
com.apple.driver.AppleUSBEHCI 5.1.5
com.apple.driver.AppleUSBXHCI 1.1.0
com.apple.driver.AppleEFINVRAM 1.6.1
com.apple.driver.AppleSmartBatteryManager 161.0.0
com.apple.driver.AppleRTC 1.5
com.apple.driver.AppleACPIButtons 1.6
com.apple.driver.AppleHPET 1.7
com.apple.driver.AppleSMBIOS 1.9
com.apple.driver.AppleACPIEC 1.6
com.apple.driver.AppleAPIC 1.6
com.apple.driver.AppleIntelCPUPowerManagementClient 196.0.0
com.apple.nke.applicationfirewall 4.0.39
com.apple.security.quarantine 2
com.apple.driver.AppleIntelCPUPowerManagement 196.0.0
com.apple.driver.AppleThunderboltPCIUpAdapter 1.2.5
com.apple.iokit.IOFireWireFamily 4.5.5
com.apple.driver.IOBluetoothHIDDriver 4.0.9f8
com.apple.driver.AppleMultitouchDriver 235.27
com.apple.iokit.IOSerialFamily 10.0.6
com.apple.kext.triggers 1.0
com.apple.iokit.IOSCSIArchitectureModelFamily 3.5.1
com.apple.driver.DspFuncLib 2.3.0f2
com.apple.iokit.IOAudioFamily 1.8.9fc9
com.apple.kext.OSvKernDSPLib 1.6
com.apple.driver.AppleBacklightExpert 1.0.4
com.apple.iokit.AppleBluetoothHCIControllerUSBTransport 4.0.9f8
com.apple.driver.AppleSMBusController 1.0.10d0
com.apple.driver.AppleSMBusPCI 1.0.10d0
com.apple.driver.X86PlatformPlugin 1.0.0
com.apple.driver.IOPlatformPluginFamily 5.2.0d16
com.apple.driver.AppleHDAController 2.3.0f2
com.apple.iokit.IOHDAFamily 2.3.0f2
com.apple.nvidia.nvGK100hal 8.0.0
com.apple.NVDAResman 8.0.0
com.apple.iokit.IOSurface 86.0.2
com.apple.iokit.IOBluetoothFamily 4.0.9f8
com.apple.driver.AppleSMC 3.1.3d11
com.apple.driver.AppleGraphicsControl 3.2.6
com.apple.iokit.IONDRVSupport 2.3.4
com.apple.iokit.IOGraphicsFamily 2.3.4
com.apple.driver.AppleThunderboltDPInAdapter 1.8.5
com.apple.driver.AppleThunderboltDPAdapterFamily 1.8.5
com.apple.driver.AppleThunderboltPCIDownAdapter 1.2.5
com.apple.driver.AppleUSBMultitouch 235.7
com.apple.iokit.IOUSBHIDDriver 5.0.0
com.apple.driver.AppleUSBMergeNub 5.1.5
com.apple.driver.AppleUSBComposite 5.0.0
com.apple.driver.AppleThunderboltNHI 1.6.0
com.apple.iokit.IOThunderboltFamily 2.0.3
com.apple.iokit.IOUSBUserClient 5.0.0
com.apple.iokit.IO80211Family 500.15
com.apple.iokit.IONetworkingFamily 3.0
com.apple.iokit.IOAHCIFamily 2.2.0
com.apple.iokit.IOUSBFamily 5.1.6
com.apple.driver.AppleEFIRuntime 1.6.1
com.apple.iokit.IOHIDFamily 1.8.0
com.apple.iokit.IOSMBusFamily 1.1
com.apple.security.sandbox 220
com.apple.kext.AppleMatch 1.0.0d1
com.apple.security.TMSafetyNet 7
com.apple.driver.DiskImages 344
com.apple.iokit.IOStorageFamily 1.8
com.apple.driver.AppleKeyStore 28.18
com.apple.driver.AppleACPIPlatform 1.6
com.apple.iokit.IOPCIFamily 2.7
com.apple.iokit.IOACPIFamily 1.4
com.apple.kec.corecrypto 1.0
System Profile:
Model: MacBookPro10,1, BootROM MBP101.00EE.B00, 4 processors, Intel Core i7, 2.6 GHz, 16 GB, SMC 2.3f32
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 512 MB
Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 1024 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D5434314753364D465238432D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D5434314753364D465238432D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xEF), Broadcom BCM43xx 1.0 (5.106.98.81.20)
Bluetooth: Version 4.0.9f8 10405, 2 service, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM256E, 251 GB
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1d100000 / 2
USB Device: hub_device, 0x0424 (SMSC), 0x2512, 0x1d180000 / 3
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0262, 0x1d182000 / 5
USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x1d181000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8286, 0x1d181300 / 8
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1a100000 / 2
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8510, 0x1a110000 / 3
 

benthewraith

macrumors 68040
May 27, 2006
3,078
80
Miami, FL
My issue isn't really the same but since my ML upgrade my time machine backups have been painfully slow over what is meant to be a fast USB3 connection...
Ever since Mountain Lion, my external hard drive's permissions have prevented me from doing anything without typing a password. I don't want to have to reformat it. :(
 

philxor

macrumors regular
Dec 21, 2010
181
0
I'm also having an issue with TM backups, they start and then hang and take forever. I'm about to reformat the drive and see if that helps.
 

trickness

macrumors member
May 13, 2012
48
10
Slow to access

Since I "upgraded", it takes my Macbook Pro a lot longer to access my Firewire 800 drive, seems to be putting it to sleep or something. CD rips take way longer too, there's definitely something going on.
 

hafr

macrumors 68030
Sep 21, 2011
2,743
5
I'm also having an issue with TM backups, they start and then hang and take forever. I'm about to reformat the drive and see if that helps.
Do they actually start, or are you stuck at "preparing..."? Check console to see if TM is just doing a deep scan of the backup, it might be that. In that case, just let it take its time.
 

PCWebbJR

macrumors member
Original poster
Jun 20, 2012
83
0
Chicago, Illinois
Since I "upgraded", it takes my Macbook Pro a lot longer to access my Firewire 800 drive, seems to be putting it to sleep or something. CD rips take way longer too, there's definitely something going on.
Yea, my drive is firewire 800. when i restart it takes eternity to shut off and when I boot up there are freezes. TM takes forever to back up as well.
 

ixodes

macrumors 601
Jan 11, 2012
4,430
2
Pacific Coast, USA
Our Solution.

Try this, we had this problem at work with five rMBP's, it fixed ours.

Go to: System preferences / uncheck sleep hard drive.
 

RWinOR

macrumors 6502
My issue isn't really the same but since my ML upgrade my time machine backups have been painfully slow over what is meant to be a fast USB3 connection...
I am also have major issues with Time Machine. I was trying to back up via Airport Extreme to a Western Digital 3 TB drive. It took over 2 weeks to back up 630GB!! Then it reported the backup was corrupted and needed to be redone. URgh. So I tried to restart it to no avail It would just sit for days reporting preparing HD, how long does that take?????.

Hooked my drive straight into my computer, It has been running for about 3 days and only has 100gig. WTF???

My machine just locked up again for about the 20th or so time in the past few weeks. I rebooted and now for the second time my hard disk is read only. I cannot even move an icon on my desktop!

I called apple support for help to uninstall ML and put Lion back, they said to do a fresh install. Great, Mountain lion cleared my previous Lion backups off my back up disk. That means if I go this route I have now lost Everything!

While the back up is running every other system is painfully slow, yet the back ups do not happen in a timely fashion. Where is all the processor power going????

At this point I am not very excited about Mountain Lion. Worst upgrade ever.
 

hafr

macrumors 68030
Sep 21, 2011
2,743
5
I am also have major issues with Time Machine. I was trying to back up via Airport Extreme to a Western Digital 3 TB drive. It took over 2 weeks to back up 630GB!! Then it reported the backup was corrupted and needed to be redone. URgh. So I tried to restart it to no avail It would just sit for days reporting preparing HD, how long does that take?????.

Hooked my drive straight into my computer, It has been running for about 3 days and only has 100gig. WTF???

My machine just locked up again for about the 20th or so time in the past few weeks. I rebooted and now for the second time my hard disk is read only. I cannot even move an icon on my desktop!

I called apple support for help to uninstall ML and put Lion back, they said to do a fresh install. Great, Mountain lion cleared my previous Lion backups off my back up disk. That means if I go this route I have now lost Everything!

While the back up is running every other system is painfully slow, yet the back ups do not happen in a timely fashion. Where is all the processor power going????

At this point I am not very excited about Mountain Lion. Worst upgrade ever.
Have you tried using Carbon Copy Cloner instead? It's free for 30 days, so worst case scenario you just back up your computer using CCC and then do a clean install of Lion. Then just go into your CCC backup and take whatever you need from there.
 

olkhovp

macrumors newbie
Mar 6, 2008
14
0
Virginia
VERY SLOW ML TimeMachine Backup to perfectly good external HD

My 2 cents: I am using a 2010 iMac and tried a completely new 250+Gb Time Machine copy to a WD Passport USB 2.0 500Gb external HD. It's taking like more than 2 days. Never took that long before. Not a web or wi-fi issue. Before Mountain Lion, should have taken 3-4 hours max. Any ideas?
 

RWinOR

macrumors 6502
My 2 cents: I am using a 2010 iMac and tried a completely new 250+Gb Time Machine copy to a WD Passport USB 2.0 500Gb external HD. It's taking like more than 2 days. Never took that long before. Not a web or wi-fi issue. Before Mountain Lion, should have taken 3-4 hours max. Any ideas?
I can tell you what Apple tech support told me for a similar issue. If it is not time capsule Mountain Lion will not support it. It does not mean it will not work It just means if it does your lucky and if it does not well too bad.

MY system backed up for over 2 weeks and only delivered a corrupted back up, then I hooked straight into my computer and finally bailed after a few days and only a fraction of the way done. Lion would perform the same task in less than one day through wifi.

I have had several suggestions that I move to third party back up and abandon apples time machine. That is what I am looking into.

I sure hope Apple Software Engineers are reading these post about how poorly time machine is working and fix it soon. Not sure how something so rudimentary and basic could make it through beta testing?????

Good Luck.
 

RWinOR

macrumors 6502
Please send Apple your feedback:
http://www.apple.com/feedback/macosx.html

Thanks! :)
Thanks for the link, but I have already spent > 10 hours on the phone trouble shooting providing feedback and asking how to upgrade my system back to Lion. If they do not know how I feel and how it is working for me then they are not listening or paying attention. Mountain Lion = GIANT Fail at this point. Perhaps the next service pack will fix some of the "Basic" over looks. What makes this so Disappointing for me, is everything I have gotten from Apple to this point has been stellar. I expected more from them for a major release like this. My entire home is in the Apple eco system, Routers, computers, phones, iPads, iPads etc. everything was working perfect up to this release, now I am rebooting my machine like a Windows 3.0 box. Frustrating!!!!
 

olkhovp

macrumors newbie
Mar 6, 2008
14
0
Virginia
Thanks to dolfke in Apple Support Communities Blog, running "sudo tmdiagnose" in the terninal really worked. I couldn't tell you why, but my TM backup time increased by 10X's.

For ref:

dolfke

Re: time machine very slow with mountain lion

Aug 19, 2012 6:25 AM (in response to 1tombhome)


How to run tmdiagnose


1) Launch Terminal.app (/Applications/Utilities/Terminal.app)
2) Enter the command text below followed by the Return key on the Terminal command line:


sudo tmdiagnose


3) Enter your admin password when prompted and wait for all of the tmdiagnose processes to finish.
 

zhenya

macrumors 603
Jan 6, 2005
6,440
2,917
My issue is not with Time Machine (which works great on my external drive), but in general I am having issues where restarts are often slow and at times the entire machine freezes up with my fw800 drive attached.

This is a new drive, and I've never operated long-term with a firewire drive connected to my iMac so I can't say if this issue is new to Mountain Lion or not. Is this a common issue with firewire drives and Macs, or is there something else going on?
 

jk73

macrumors 6502
Jul 19, 2012
471
119
I've had an rMBP since July 11. I had zero crashes or restart/sleep problems until the Thunderbolt-to-FireWire adapter came out and I started moving files off my old PowerBook. Since then, I've had the same issues mentioned by the OP -- e.g., two system crashes, very long shutdown and restart times, refusal to wake from sleep if the external is attached, etc.

The other day, I restarted with my PowerBook connected via TB-to-FireWire, and it was still on the start-up screen after 2 minutes. I unplugged the Thunderbolt adapter and bingo, the computer was ready less than 3 seconds later.

In my case, I should be done transferring files from my old PB within a few days, and I'll have no more use for the TB-to-FireWire adapter. I'm still happy Apple released it, but its lack of stability has been both annoying and troublesome.
 

ZipZap

macrumors 603
Dec 14, 2007
5,461
862
I just got my rMBP yesterday with ML installed. I've been using a firewire, 1TB G-Tech external hard drive with absolutely no issues to speak of until now. It it formatted with mac os extended journal.

When it is plugged in it takes forever for my computer to restart and often will freeze the system. It has gotten to the point now that I need to wipe the drive because there are so many corrupted files on it.

When it isn't plugged in my computer restarts lightning fast and has no issues whatsoever.

Clearly it's an issue with communicating to the external, but I know no more than that.

Anyone else having similar issues now that they've upgraded to ML?
I had this issue with my external HDs. I was using USB 3.0 goflex enclosures. I switched to Thermaltake Max 5Gs and the problem is completely gone. I thinks its USB 3.0 related. Apple has not implemented it well.

I do have an alternate issue since upgrading to ML....my external drives will not reconnect when waking from sleep.

I believe ML is not interrogating the drives properly. Just a guess.
 

lajji

macrumors newbie
Sep 6, 2012
1
0
Hi,
I have a very similar problem with a mbpro since I (recently) updated it to Mountain Lion. The HDD causing problems is a Seagate (ST31500341AS) connected with USB3.
I verified that it has nothing to do with Time Machine.
When connected to the mbp, it causes complete freeze of the computer (ie. impossible to do ANYthing => hard power off needed).
I'll try to remove the hdd from it's case and connect it with USB2 to check if the problems come from there....
 

KrakenChaos

macrumors newbie
Aug 26, 2012
10
0
Try this, we had this problem at work with five rMBP's, it fixed ours.

Go to: System preferences / uncheck sleep hard drive.
I was unable to use my external harddrive with exFAT partition. This helped solve the problem. It's working fine now.
 

LosGatosCat

macrumors newbie
Sep 22, 2012
1
0
Slow Time Machine Backups with Lion

I was also experiencing a multi day backup with Time Machine on a Passport Essential external drive for 170GB. I downloaded for free (a request for a donation appears, which you can decide on later); it works beautifully and my 170GB backed up in 90 minutes on my Passport Essential. I'll make the donation. IBackup appears to be very clean. I'll wait till Apple cleans up the problem with Time Machine backups, but Ibackup is a great alternative.