Issues with mounting NFS point to ML server

Discussion in 'Mac OS X Server, Xserve, and Networking' started by MrMattFoley, Oct 3, 2012.

  1. MrMattFoley macrumors newbie

    Sep 22, 2012
    Alright, here goes.

    The company I work for has been using SL server for years and wanted to test a possible upgrade to ML server for NFSv4. Downloaded ML to test machine and ML server. I mounted it via server connector (nfs://blah get the idea) volume that I want to share comes up on desktop but will not show under the server app. I also have access to posix but I need full access to acl as well.

    I'm trying to figure out how to access this NFS share so that I can share it from the server but cannot seem to get it working. To those who know OSX servers I probably sound like a moron, but I'm just an I.T. guy tasked with setting up a test server even though I'm not a "server guy". Any information would be greatly appreciated.

    One more question. Would a migration from SL to ML server also bring along this volume? Thanks again.

  2. switon, Oct 8, 2012
    Last edited: Oct 8, 2012

    switon macrumors 6502a

    Sep 10, 2012
    RE: NFS with ACLs...


    Under Mac OS X 10.6.8 Server, you could use the ServerAdmin app to setup both POSIX and ACLs on a NFS share. I believe that the under Mountain Lion no longer provides a GUI access to these features. This is not to say that you can't do this, just that you will be restricted to using Terminal commands and perhaps an editor to setup NFS the way you want.


    P.S. Yes, as Apple progresses with its OS X Servers from SL to L to ML, more and more features are being eliminated from the server's GUI app. It doesn't mean that these features are unavailable, just that you have to use commandline commands and an editor to regain access to these features.
  3. MagnusVonMagnum macrumors 601


    Jun 18, 2007
    This is a shame because my ancient PowerMac worked with XBMC on Gen1 AppleTV perfectly fine using SMB. Upgrading to a new Mac Mini Server, SBM no longer works right at all (you can browse, but not play anything). AFP support in XBMC Eden (last version that will supposedly work with Gen1 ATV running Apple's own interface, at least) is bugged (i.e. it will play for 15-30 minutes or so and then crash XBMC and so AFP support in XBMC is pretty much worthless and they have no intention of fixing it). That leaves NFS (which you now have to configure with a freaking shell window or pay someone in the UK around $30 for their GUI configuration program OR you can replace Apple's SMB stuff with 3rd party software (no idea how that might affect or be affected by OSX updates in the future) OR you can try and set up UPnP and/or WebDav (latter should be easy under OSX Server, but so far I just get dead-ends inside XBMC when zeronconf browsing the WebDev links that came up).

    The end result is I have a non-functioning XBMC setup at the moment on my brand new Mac but my old Mac has zero iTunes and Apple support and has lousy browser support, etc. and is slow as heck. It's just sad that Apple has always portrayed itself as the computer that just works and yet it's so darn hard to get something as simple as an XBMC share to work with OSX properly (and you can blame Apple or XBMC; I don't care which since neither side will fix their incompatibilities and Gen1 ATV support is gone on the XBMC side so even if they do fix it, it will never show up for the older AppleTVs without me having to dump Apple's interface.
  4. penlock macrumors newbie

    Sep 28, 2013
  5. alexrmc92 macrumors regular

    Feb 7, 2013
    As far as i know, Mountain Lion's Server app will not show network shares as storage, only physical storage will be shown.

    The only exception is time machine.

    You could try iSCSI, but people have mixed results with it.
  6. MagnusVonMagnum macrumors 601


    Jun 18, 2007
    Two things fixed my SMB issues with Mountain Lion. With 10.8.5, it broke something, but re-installing SMBUp fixed it. My other problem was apparently with the transfer to the new computer. Somehow the group read permissions got screwed up on a lot of directories (or were ignored before) and that's why I couldn't access some files from XBMC. I blanket corrected the entire drive to read-only for ALL and I've had zero problems with SMB with XBMC Eden on the old AppleTV units with my new Mac Mini ever since.

Share This Page