Issues with my MacBook Pro, bought used

Cero

macrumors newbie
Original poster
Jan 9, 2015
3
0
Hello, today I got my MacBook Pro 15. It's the retina model from mid 2012.
I'm having some issues, however I don't know what might be the cause.

When I installed Yosemite, the agreement loaded very slowly. In the last steps there's the animation of three checks: the last one took some minutes to appear... Reinstalling Yosemite on my old MacBook Pro 13 2011 was really faster and this precise step took a second.

Using that seems fine, however I'm having some issues with WiFi and Bluetooth. The first time, before reinstalling Yosemite, I restored from time machine and wifi didn't connect at all.
Then I reinstalled the operating system and now it works. Wifi works almost fine, but at times it's slow. I tried changing the dns with little results...
Bluetooth also seems buggy: it has troubles connecting to my Harman Kardon Soundsticks BT. When it works, the audio is sluggish, and I don't understand why since it works really fine with my iPhone.
My Magic Mouse had, one time, a significant lag. Rebooting solved that, but the audio still has issues.

Do you have any idea about what might cause that?
Do you know if connection is used during the first account configuration? Do you think I might solve changing my wifi/bt card?
 

soupcan

macrumors 6502a
Nov 21, 2014
732
2,926
Netherlands
If you're on 10.10.3, yeah, WiFi on that OS X version was buggy as bananas. 10.10.4 was released today though, which is supposed to fix the WiFi issues. Same might go for the BlueTooth issues, but that can also be a faulty WiFi/BlueTooth card.
 

Cero

macrumors newbie
Original poster
Jan 9, 2015
3
0
I never had issues with 10.10.3 on my older MacBook! However I'll update as soon as I get home, thanks
 

Cero

macrumors newbie
Original poster
Jan 9, 2015
3
0
It's not solved. The problem seems to relate with radio signal interferences with wifi 2.4ghz and Bluetooth. Not sure it can be fixed with a software update...