Issues with nvidia 760 Ti (Dell/Alienware OEM)

Discussion in 'Mac Pro' started by austinpike, Mar 6, 2016.

  1. austinpike, Mar 6, 2016
    Last edited: Mar 6, 2016

    austinpike macrumors 6502

    Joined:
    Oct 5, 2008
    Location:
    MN
    #1
    So I bought this card on Craigslist... (always a good start to a story.)

    Listing was a bit unclear, said 760 in one spot, 760Ti in another. Card is completely unbranded, black 760-style reference shroud. Since the 760Ti is pretty rare and apparently OEM-only, I figured it was most likely just a 760. From what markings there are I've concluded it is an OEM Dell/Alienware 760 Ti.

    Unfortunately the only port that seems to work in my 5,1 CMP (El Cap) is the DVI-I (paired with a GT 120 for boot screen.) Nvidia drivers are installed and IDs it as a "GeForce GTX 760 Ti OEM." I get nothing on Displayport, DVI-D, or HDMI.

    I tried the card in two other machines, Ivy Bridge era.
    Z68 Gigabyte board - No bios/splash screen, nothing on windows boot. (on any port.)
    Z77 Quo (hackintosh) board - I get Quo bios splash screen on DVI-I, nothing on any other port. Won't progress beyond that and I can't enter bios setup or boot loader.

    So I have no idea if the card is defective or if there is some Dell-specific firmware on this thing causing problems? BIOS/UEFI issue? I have no idea what the Alienware would have shipped with. I mainly bought it for the CMP, so I can use the DVI-I as-is, but it would be nice to have more than one port. Since that probably isn't going to happen I would eventually pass it down for kids' minecraft duty, but it won't boot at all in those machines...

    Would consider sending to macvidcards for flashing, but I don't see a 760 Ti on their menu. And I'd hate to throw good money after bad if the thing is a dead end.


    edit:
    also tried inZ77E Asrock (UEFI) - Boot screen and boots to Windows only on DVI-I, nothing on any other port. So obviously it is happier with UEFI. But still only having one port working is not ideal.
     
  2. Squuiid macrumors 6502a

    Joined:
    Oct 31, 2006
    #2
    Sounds like it needs a BIOS reflash. You need to 100% ID that card and then find the correct BIOS rom and flash it using nvflash.
     
  3. austinpike thread starter macrumors 6502

    Joined:
    Oct 5, 2008
    Location:
    MN
    #3
    To follow up on this in case it helps anyone else....

    I read elsewhere that the 760 (or at least some of them) require UEFI to boot. So that explains the no-boot w/legacy BIOS machines.

    I tried the BIOS flash. (thanks Squidd)

    Stock BIOS made no difference. I also flashed it with a 670 ROM. (The OEM 760Ti is apparently exactly the same card.) This allowed it to boot on a legacy BIOS, but the other ports still did not work. With a monitor plugged in, they would show up in the Windows control panel, but no image would display on screen. At this point I assume the other ports must simply be defective.

    The seller was understanding, and had offered a refund up front if I had problems. I hate to be "that guy" as I generally view CL as caveat emptor, but I took him up on it. Turns out he had previously sold it to someone else who was also not able to get it to work. I'm assuming the seller had only ever used it with DVI-I and thought the card was fine.

    I've since picked up a deal on a 680 which I expect to have a much better time with.
     
  4. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #4
    The 680 is wonderful and easily flashed with Mac EFI. I think you'll be much happier with it.
     

Share This Page