Resolved Issues with TDM, Clean Install...

Discussion in 'MacBook Pro' started by rawweb, Apr 10, 2017.

  1. rawweb macrumors 6502a

    rawweb

    Joined:
    Aug 7, 2015
    #1
    I obtained a 2012 15" Retina MacBook from a local college sale that I'm currently investigating. Sale is always 'as is', no returns. I've had good luck with the sale in the past...

    The unit itself was heavily discounted because it's missing it's lower case screws, but booted right up. The case is in near flawless condition. I also made note on inspection that the SSD screw was missing.

    After attempting a few clean installs with various versions I've noticed some behavior that makes me believe the ram is bad. I can't boot into the diagnostic utility to verify. Nor can I initiate a clean install...Install always fails. The basics of course, SMC and PRAM offer no quick resolution. Certainly some moron sale tech could have fingered the soldered ram with the case being off and zapped it.

    I'm able to boot using my 2011 13", 2014 15" and 2016 15" via Thunderbolt-TDM. Everything works great, producing no strange symptoms. I've run multiple tests including strenuous games and did some video encode exports to stress the machine. Everything worked fine.

    Hoping it's just the hard drive, I ordered a replacement from OWC. It arrives today..

    Now it gets funny...My 2011's SSD and 2014's SSD all became corrupt shortly after being connected to the machine. The machines would no longer boot and would shut off half way through boot. Never seen something like this before. Using another working machine via TDM, verify/repair fails in Disk Utility. I can fix the drive with Disk Warrior, and all is working fine again...Never seen this before and makes me think some kind of virus, the common connection, this suspect 2012. Any ideas out there?
     
  2. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #2
    That is curious about the drive corruption. Could be coincidence, hard to see how it could be anything else. But I had software issues with my 2011 that I thought might have corrupted my HDD. I haven't yet tried to fix it to see if it was really just physically failing.
     

Share This Page