Issues with the Adonit Jot Pro stylus and iPad Air/iOS7

Discussion in 'iPad Tips, Help and Troubleshooting' started by lewisd25, Nov 7, 2013.

  1. lewisd25 macrumors 6502a

    Joined:
    Jul 6, 2007
    #1
    Has anyone else had issues using the Adonit Jot Pro styluses with iPad Air?

    I own three Jot Pros which work perfectly on my iPad 3 and 1st gen iPad mini, both of which run iOS 6. Notability is the note taking app I use.

    With the new iPad Air, all three styluses are exhibiting issues with responsiveness and accuracy. I'm experiencing about 50% of my strokes not registering. I'm familiar with using thermal compound on the joints to improve accuracy, but that isn't working.

    I can turn around and use the same styluses on my iPad 3 without issue. Is this a side effect of the new screen technology Apple is using in the Air?
     
  2. Coaxilotl macrumors newbie

    Joined:
    Nov 16, 2013
    #2
    Finally applied a screen protection film to the iPad Air and tried the Jot Pro. Massive loss of responsiveness. Same on an iPad 2 with IOS 7. This is not funny :(
     
  3. henjin macrumors member

    henjin

    Joined:
    Jun 19, 2007
    #3
    Many 3rd party SDKs have been broken by iOS 7

    Apparently the AIR uses a different frequency, so until Adonit updates it's SDK and the Apps you use take heed nothing will change.
    This is why Apple is losing market share to Samsung and why serious artists are buying the Wacom Cintique Companion or Hybrid as Apple still insists we use our fingers. Samsung has a stylus that merely lacks the range of Apps we have in iOS but Apple needs to do make a stylus that does not need Bluetooth.
    I use a Wacom Cintique Companion Windows8 for serious work and a Pogo Connect on my iPad 4. The new Wacom Bluetooth pen works on the iPad AIR.

    Samsung will eat Apple's lunch if they do not do more than insist we finger paint or lose the use with 3rd party stylus whenever the hardware and/or iOS changes. This is a nonsense to pay so much for so little.

    I can understand your annoyance. Buy the Wacom....
     
  4. Coaxilotl macrumors newbie

    Joined:
    Nov 16, 2013
    #4
    I finally solved most of my issues with the Adonit. By chance I removed the plate from the tip and the tip from the pen, then assembled all parts together again - surprise. Works quite well now :cool:
     

Share This Page