Issues with wireless connectivity on MacBook

Discussion in 'Mac Basics and Help' started by outonalimb, Mar 6, 2008.

  1. outonalimb macrumors newbie

    Joined:
    Mar 6, 2008
    #1
    I have a Draytek Vigor 2800G wireless router and a new MacBook (Penryn model). However, I am struggling to get connected wirelessly.

    In the airport software (icon at top of screen), my MacBook sees the SSID and allows me to type in my WPA key. It then connects and allows me to connect to the internet for 5 seconds. The connection then times out.

    After timing out, Safari prompts me to click a Network Diagnostics button which then gives me a wizard to troubleshoot the connection. I reenter my WPA key and run through the wizard and the connection comes back alive and works indefinately.

    When I close my MacBook and restart the next day, I have to follow the same procedure again.

    This surely cannot be normal behavior? My IBM Thinkpad running Windows XP is having no issues - i just open the lid and it auto connects to my wireless network.

    I am new to Mac's so any help would be really appreciated.

    Thanks.
     
  2. youmustagree macrumors newbie

    Joined:
    Mar 7, 2008
    #2
    Penryn MBP Draytek Wifi Issues

    I have a new MacBook Pro (Penryn) with the same wifi problems. I am using a Draytek Vigor 2800VG with firmware 2.8.1. I have tried using both OSX 10.5.2 and Windows Vista in bootcamp.
     
  3. rmccorkl macrumors newbie

    Joined:
    Mar 8, 2008
    #3
    Concur

    Yeap this is the same issue I found when taking receipt of a new Macbook and some extensive testing (eg upgrade firmware in my modem 2.8.1) I could not resolve any DNS entries even though I'd successfully negotiated a IP address using DHCP. After some intensive investigation I discovered doing a simple ping test to my router that network connection was dropping packets anything from 10-90%. With massive response times. I logged a support call with apple, and went through everything making my network open etc.

    What was confusing is that I have also a MacBook Pro and other computers all connecting fine but this new macbook. Finally as a finally test the enginneer suggest a boot of the DVD and do another network test which showed again packet loss.

    At that point they agreed that it sounded like a bad airport card or connection. So they agreed to replace the macbook, which they did. As soon as I got the new macbook, you guessed it same problem.

    So I thought this must be something to do with my modem Draytek vigor 2800 VG and some incompatibility with these new MacBook either the airport card of the drivers in 10.5.2.

    So to prove this I pulled out an old BT HomeHub modem and activated the wireless network to be the same settings as my Draytek. The macbook connected to the home hub and when doing a ping test was a 100% successful with NO packet loss.

    I've reported this back to apple's support centre. It would help if the people on this thread and anyobe else effected did the same to give it there attention as this is potentially a big problem if this incompatibility effects other makes of ADSL modems. This thread confirms that 2800 family is effected :eek:
     
  4. Snorsh macrumors newbie

    Joined:
    Jan 19, 2008
    Location:
    Toronto, Canada
    #4
    Having the same problem with a Linksys router. All was fine for about three months, and then my MacBook will only connect as far as the router, no internet connection. This only occurs with my home network.
     
  5. johanv2600 macrumors newbie

    Joined:
    Mar 18, 2008
    #5
    Can confirm the issue of the Penryn MBP with the Draytek 2800 series also: flawless wireless connection with my home Draytek 2600WE, problems with the office 2800G. Direct Ethernet connection to the 2800G works fine, so it is really the wireless part playing tricks on us. Sure would like to see this solved ASAP.
     
  6. Snorsh macrumors newbie

    Joined:
    Jan 19, 2008
    Location:
    Toronto, Canada
    #6
    Try checking the DNS settings on your router. This solved my problem. Good luck
     
  7. FloridaBSD macrumors newbie

    Joined:
    Mar 18, 2008
    Location:
    Broward County, FL
    #7
    Sounds to me like you all need to check you router Manufatturers websites for firmware upgrades as this si usrally a sign that there is a problem the the routers firm ware it self.
     
  8. vrolijkje macrumors newbie

    Joined:
    Mar 5, 2008
    #8
    i'm sorry but that is incorrect. you cannot simply blame the software of the modem. Like above is said the connection is ok and at some point in time the connection is dropped and keeps on doing that.

    I am experiencing the same problems here (europe/ netherlands/ ADSL) with an ASUS WL-500W router.

    WindowsXP (DELL) laptop runs like a dream, my (new) macbook is constantly searching for network and safari drops every now and then.. regardless if i'm very close or far far away from the router...

    rebooting the router sometimes helps... :confused:

    so far for :apple: ease of use :rolleyes:
     
  9. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #9
    You need to go through the normal steps of power cycling. Turn everything off (after checking your router settings in the browser to see if they are right and no interference from other networks). There are certain great widgets to check for channel overlap and signal strength.

    Then turn on the modem and let it start up, next the router, then your next computer and connect to the network, then every other computer in sequence.
     
  10. vrolijkje macrumors newbie

    Joined:
    Mar 5, 2008
    #10
    solution..

    it's also a way to get your customers to stick with your products...
    i bought a :apple: Airport Express and now the signal is PERFECT, no more drops or so...

    happy guy but again €89 investment in my Apple gear :rolleyes:
     
  11. ffrut macrumors newbie

    Joined:
    May 6, 2008
    #11
    Fix

    OK chaps - I think I can help you (or at least some of you). ;)

    The initial problem description exacly matches my own issue. My wife purchased a new Macbook (not Pro) in March and we found it would not connect and stay connected to the perfectly good wireless network in our house.

    Draytek 2800VG, channel 11, 11b only, WPA/TKIP working just fine with my IBM Thinkpad and the Wii but no go with Macbook. However, the Macbook was absolutely fine when physically plugged into one of the Draytek ethernet ports. All firmware up to date.

    Problem is an incompatibility between the Broadcom wireless chipset now being fitted into the latest Macbooks and the Atheros (I think) chipset in the Draytek.

    Solution is to purchase a Broadcom based wireless access point and plug it into one of the Draytek ethernet ports. Fixed in an instant and wife happy.

    Model I used is a Linksys WAP54G version 3.1 purchased in the UK. Be aware that Linksys use various wireless chipsets so please do your research before purchasing any other model.

    This incompatibility between wireless chipsets may occur with other manufacturers' equipment and as they all seem to use multiple chipsets, it cannot be assumed that any one manufacturer will work.

    Good luck!
     
  12. outonalimb thread starter macrumors newbie

    Joined:
    Mar 6, 2008
    #12
    Thanks for all the responses. Not matter how hard I tried and researched I couldn't find a possible solution. The broadcom compatibility issue with the Draytek sounds plausible but I eventually went out and replaced the Vigor with a cheap Netgear 834G v4 model. This works fine with my new MacBook and my IBM Thinkpad with no issues whatsoever.

    It's a shame really as the Vigor offers so many features that are useful for home and small business. Maybe the new models work fine but I couldn't justify the cost vs the Netgear at present.
     
  13. mac jazz macrumors newbie

    Joined:
    Dec 6, 2008
    #13
    Same issue

    I am experiencing exactly the same issue.

    Draytek 2800VG works perfect with older MacBook and iPhone 3G, but does not work with newer MacBook

    Airport Express works perfect with all devices tried so far.

    I also suspect a hardware incompatibility between Draytek hardware and new MacBook.

    From OSX system profiler:

    New MacBook:
    - Model: MacBook 2,1
    - Firmware Airport: *Broadcom BCM43xx 1.0 (5.10.38.9)

    Old MacBook:
    - Model: MacBook 3,1
    - Firmware Airpot: 1.4.8.0

    => different Airport cards, both MacBook Core2Duo
     
  14. ffrut macrumors newbie

    Joined:
    May 6, 2008
    #14
    Fix still good.....

    I can confirm that my solution of using a Broadcom based wireless AP plugged into the Draytek Ethernet still works great.

    So much so that I turned off the Draytek wireless completely and use the AP as the sole wireless for the house.

    Bonus (and I don't entirely understand the technical reasons why) is that when I turned off wireless on the Draytek, I got an almost 50% increase in the sustainable broadband speed - went from sub 2Mbits to 2.7Mbits (BT 'up to' 8Mbits service (ha!)).
     
  15. eji macrumors 6502

    eji

    Joined:
    Jun 8, 2004
    Location:
    Inland Empire
    #15
    Check to see if there's a recent firmware upgrade for your 2800. I had a look on DrayTek's site and v2.8.2 from June is listed as the latest. If your firmware is 2.8.2 and you're still having problems, read on:

    Two days ago DrayTek sent me release candidate (RC) firmware for the Vigor 2910VG. It solves all the wireless problems I'd been having with Leopard, and now my entire home network -- Intel iMac and MBP, iPod Touch, iBook G3, Canon MP600R -- is using this router for the first time since I bought it six (or more) months ago.

    How is this good news for 2800 users? Well, it shows that the problems can be fixed through a firmware upgrade, contrary to vrolijkje's wisdom. DrayTek might be working on updated firmware for the 2800, or at the very least they might have isolated the cause of the incompatibilities and can theoretically fix them across the entire Vigor range.

    I had to send a polite complaint to the PR department (press@draytek.com) before my support requests were taken seriously. I'd recommend opening a ticket with support@draytek.com and then, if the problem persists and no help is forthcoming, sending in a dissatisfied customer e-mail to the PR dept.

    Hope that helps frustrated Vigor users! I'm thrilled to have finally ditched the supplementary D-Link I was using to connect wirelessly.
     
  16. Donkeh macrumors newbie

    Joined:
    Jan 21, 2009
    #16
    Hi all, my first post - hopefully it's a useful one for some of you !

    I had the same problems with my new macbook and was bitterly disappointed - having come from a PC with no problems ;)

    Anyway - I sorted myself a Belkin access point to tide me over and began to talk with the Belkin support team.

    A few weeks later they gave me a beta copy of firmware which has fixed the issue and my macbook now talks happily to my 2800 !

    You can get the beta firmware from here... http://www.draytek.co.uk/support/download/v2800_2821_b1120_beta.zip

    (I should add this is the UK version..)

    Regards,

    Leon
     
  17. adebookpro macrumors newbie

    Joined:
    May 29, 2009
    #17
    AWESOME! Thanks - I was just about to give up and send my new Mac Mini back when I saw this. All sorted! :D
     

Share This Page