iSync - The sync manager is not available

Discussion in 'Mac Apps and Mac App Store' started by gortw4j, Dec 15, 2009.

  1. gortw4j macrumors newbie

    Joined:
    Oct 16, 2009
    Location:
    Centurion, South Africa
    #1
    Greetings,

    I had permission troubles, but iSync was working perfectly. I repaired all permissions with Leopard, then upgraded to Snow Leopard, now when I try to open iSync, I get this message:

    iSync can't be launched.
    The sync manager is not available.

    I tried many suggestions, even http://support.apple.com/kb/TS1627?viewlocale=en_US no luck...

    Any suggestions?
    Thanks!
     
  2. gortw4j thread starter macrumors newbie

    Joined:
    Oct 16, 2009
    Location:
    Centurion, South Africa
    #2
    Can someone please help me reinstall iSync? I checked my install DVD with Pacifist, but I am not able to install iSync from there. Maybe I just don't know how to do it.

    Can someone maybe give me a link to download iSync.app?

    Please!

    Thank you!
     
  3. jcbecker macrumors newbie

    Joined:
    Jan 3, 2010
    #3
    same problem here

    I'm having the same troubles. I can log in as a root user and I still get:
    "Sync can't be launched.
    The sync manager is not available."

    It was working. I had some permission troubles with Firefox and Mail, and when I got those sorted out, my iPod Touch stopped being able to sync in iTunes...

    The problem is on a MBP 15" from 2008. I sync it to a 13" MBP with ChronoSync and ChronoAgent, but preferences and applications are excluded. Both machines run 10.6.2... Documents, bookmarks, mail, iTunes Library. I'm willing to blame a setting in ChronoSync causing the permission issues, but I have it set exactly how they recommend, and it was working until last week without trouble...

    Thanks!
    Jesse
     
  4. htam95 macrumors newbie

    Joined:
    Feb 11, 2010
    #4
    I'm having the same problem as well! Running Snow Leopard. Isync 3.1 quite on me. Says "isync can't be launched," and "sync manager not available."

    Does someone have an isync.app thats 3.1 for Snow Leopard?
     
  5. Prototd macrumors newbie

    Joined:
    Mar 3, 2010
    #5
    Me, too.

    Has anyone discovered a resolve for this problem? I have searched high and low. I even went into Terminal to reset Sync Services, but got a fail. And Apple's resolve from their support assumes you have a MobileMe account, which I don't.
     
  6. jcbecker macrumors newbie

    Joined:
    Jan 3, 2010
    #6
    Sorry for the delay in posting a follow-up... and I unfortunately forget some of the details on the solution, but as far as I can remember it was a corruption in the preferences file. AppleCare Help walked me through this...

    1. I got iSync to work as a root user (I wasn't logging in as root properly. Enable root user, restart the computer and log in as "root").
    2. While in root user I pulled the preferences file out of the user account (Users/'user'/Library/Preferences) and put it on the desktop (and renamed it "old-Preferences").
    3. Restart your computer and log in as the user you are having problems with. See if iSync works. Now all of your programs will have their default preferences.
    4 So that you don't have to reset all the preferences, you can pull the preferences (.plist files) that have nothing to do with iSync out of "old-Preferences" and put them into the new file that your computer will automatically makes ('user'/Library/Preferences) to replace the one you moved.

    To figure out which .plist file it was, you would have to move them back one at a time and test iSync after each one. I didn't take the time to do that, so I don't know which file it was. Most of my preferences were pretty close to the default so it wasn't worth the effort. As usual, make sure you back up all your data before you start making changes...
     
  7. valerina macrumors newbie

    Joined:
    Mar 17, 2010
    #7
    I fix it !

    1. There is no need to log in as ROOT about removing files if you are administrator
    2. You need just to trush the file, named com.apple.syncserver.plist. It is inside Users/'Your username'/Library/Preferences
    3. It is not bad idea to repair with First Aid the Keychain and to Clear the cash using /Applications/iSync/Preferences...
    4. Now You can start sync with Mobile me.

    If You still have problems:
    1. Go to MobileMe and revoke your certificate and password
    2. Go to iChat and take another certificate
    3. Go to Mobileme preference pane and log out
    4. Go to Airport app and change the password
    5. Go to MobileMe preference pane again and
    5.1. Log in
    5.2. Turn on the Back to My Mac
    5.3. Unsign your username from syncing with Mobile me
    6. Try to sync

    7. This step is in case p.6 is not successful:

    If you upgrade your OS in this process you have to create a new account.
    I had migrated from SL to SL Server, so I wanted both: my old account and my new account.
    That's why I manually moved my old home folder to my new folder.Then I deleted the old account incl. home folder. But because of moving, many of preferences wasn't working correctly. That's why I signed as a root and renamed home folder as my old home folder. Then I created a new user which is associated with home folder. I log out root and log in as the user. Removed the account and correct my full name. After that I returned to MobileMe preferences and unregister it from syncing. Log out mobile me and log in were the next steps. Now after registering I fully sync by replacing all on my mac with those from Mobile Me.

    Best regards: Valeriya Simeonova

    PS: I had the same problem as alert messages, but upgrading from Snow Leoprad to SL Server. In the process I made a new profile, and then manually moved all items from the old home folder.
     
  8. VaughnSC macrumors newbie

    Joined:
    Jul 15, 2008
    #8
    Ah, thanks for that. I'd been having this problem for 6 months and just couldnt find the time to deal with it. Having done this before unsuccesfully, I also went to the terminal and followed this tip:

    cd ~/Library/Application\ Support/SyncServices/
    mv Local Local_bak

    After restarting, the Sync tab in the MobileMe preferences pane started working correctly.
     
  9. goatmonger macrumors newbie

    Joined:
    Jul 24, 2008
    #9
    Thanks valerina,

    I fixed by problem by repairing the keychain. Seems some permissions were set incorrectly.
     

Share This Page