Items don't open at startup/login

Discussion in 'OS X Yosemite (10.10)' started by Michel Goldberg, Oct 31, 2014.

  1. Michel Goldberg macrumors newbie

    Joined:
    Sep 23, 2012
    #1
    Hello everybody,
    Since I updated to Yosemite, I noticed that, sometimes, several items don't open at login (of course they are selected on preference/users and groups/startup = clumsy french translation).
    It can work fine 5 or 10 times without any problem and – for no noticeable reason – some items don't open (always the same, like Twitter for instance).
    The problem occurs on my MacBook pro retina (mid 2012) and not on my iMac (late 2012).
    It is not a big deal because I can open them "manually" but…
    Can you help ?
    What must I do ?
    Best regards.
    :(
     
  2. verdi1987, May 2, 2015
    Last edited: May 2, 2015

    verdi1987 macrumors regular

    Joined:
    Jun 19, 2010
    #2
    Did you ever resolve this issue? I am having the same problem. It is always the same applications that do not launch upon a restart or shutdown/cold boot.

    Interestingly, these apps do launch upon logoff/logon.

    I will try trashing com.apple.loginitems.plist and recreating my startup items list.

    Update: I trashed com.apple.loginitems.plist, logged off, logged back in, and then recreated my list of login items. Upon shutdown and restart, all startup apps appear to have launched.
     
  3. Michel Goldberg thread starter macrumors newbie

    Joined:
    Sep 23, 2012
    #3
    I think I trashed (without emptying) com.apple.loginitems.plist.
    And it worked : corrupted file perhaps.
    Best
     

Share This Page